MIkrotik LtAP
MIkrotik LtAP
Scoop Distribution
presents
● Certified training
Project Objectives
● GPS tracking of company vehicles with simple web interface for use by our
managers
● WiFi connectivity for our driver to have access to basic services like maps and
voice calls
● Durability
INTERNET
GP
TPS SO
HT
● LtAP or LtAP-HD
● GPS Antenna
● Web Server
● When using the LtAP-Mini, the internal GPS antenna is compromised when
the LTE modem is enabled so you will need to attach an external antenna.
● The GPS uses an active 3.3v antenna and the connector is sensitive to
damage if touched while powered on.
/system console
set [ find ] disabled=yes
GPS Configuration - LtAP-HD
/system gps
set coordinate-format=dd
enabled=yes
gps-antenna-select=external
port=serial0
Web Server Requirements
● Web server of your choice - We used Digital Ocean, 1Gb Memory, 25Gb
Storage, Ubuntu 16.04.6 x64 = $5p/m
● Apache
● PHP
● SQLite
● SSL Certificates
● RouterOS 6.40rc30 or above - Required for getting the the coordinates from
the router to the server.
● Set GPS coordinates to ‘dd’ format
● Uses ‘/tool fetch’ parameter (CLI only)
Example:
/tool fetch http-method=post
http-content-type="application/json"
http-data="{\"lat\":\"56.12\",\"lon\":\"25.12\"}"
url="https://test_server/index.php"
Posting GPS Coordinates
{
:global lat
:global lon
/system gps monitor once do={
:set $lat $("latitude")
:set $lon $("longitude")
}
tool fetch mode=http
url="https://test_server/index.php"
port=443 http-method=post
http-data=("{\"lat\":\"" . $lat .
"\",\"lon\":\"" . $lon . "\"}")
http-header-field="Content-Type:
application/json"
:put ("{\"lat\":\"" . $lat .
"\",\"lon\":\"" . $lon . "\"}")
}
Posting GPS Coordinates
/system scheduler
add interval=1m name=gps on-event=gps
Checks what day of the week it is and sends an email based in these two variables
● If it’s not Sat or Sun between 18:00 and 07:00
● If it is Sat or Sun
/system scheduler
name="after hours" on-event=after-hours start-time=startup
WiFi Configuration
Basic AP with PSK for our implementation.
Adjust your TX power once installed in the vehicle
to reduce cell size if necessary.
Mobile hotspots will require the ‘Hotspot’ package
to be installed separately.
/interface wireless
set [ find default-name=wlan1 ]
antenna-gain=0 band=2ghz-b/g/n
country="south africa" disabled=no \
frequency-mode=manual-txpower
mode=ap-bridge name=wlan2
security-profile=Profile1
ssid=Scoop-Bakkie
Management using MikroTik’s App
We manage our routers
via WiFi (mainly for
ROS updates) as our
fleet is small
● GPS Tracking with simple user interface for our management team
● Content filtering
● Mobile hotspot
Blogs
Thank You!