Manually Configured Ipv6 Over Ipv4 Tunnels: Finding Feature Information
Manually Configured Ipv6 Over Ipv4 Tunnels: Finding Feature Information
Manually Configured Ipv6 Over Ipv4 Tunnels: Finding Feature Information
This feature provides support for manually configured IPv6 over IPv4 tunnels. A manually configured tunnel
is equivalent to a permanent link between two IPv6 domains over an IPv4 backbone.
• Manual
• Generic routing encapsulation (GRE)
• IPv4-compatible
• 6to4
• Intrasite Automatic Tunnel Addressing Protocol (ISATAP)
Note Overlay tunnels reduce the maximum transmission unit (MTU) of an interface by 20 octets (assuming
that the basic IPv4 packet header does not contain optional fields). A network that uses overlay tunnels
is difficult to troubleshoot. Therefore, overlay tunnels that connect isolated IPv6 networks should not be
considered a final IPv6 network architecture. The use of overlay tunnels should be considered as a transition
technique toward a network that supports both the IPv4 and IPv6 protocol stacks or just the IPv6 protocol
stack.
Use the table below to help you determine which type of tunnel that you want to configure to carry IPv6
packets over an IPv4 network.
Table 1: Suggested Usage of Tunnel Types to Carry IPv6 Packets over an IPv4 Network
GRE- and IPv4- compatible Simple point-to-point tunnels that Can carry IPv6, Connectionless
can be used within a site or Network Service (CLNS), and
between sites. many other types of packets.
6RD IPv6 service is provided to Prefixes can be from the SP’s own
customers over an IPv4 network address block.
by using encapsulation of IPv6 in
IPv4.
ISATAP Point-to-multipoint tunnels that can Sites can use any IPv6 unicast
be used to connect systems within addresses.
a site.
Individual tunnel types are discussed in detail in this document. We recommend that you review and understand
the information about the specific tunnel type that you want to implement. When you are familiar with the
type of tunnel you need, see the table below for a summary of the tunnel configuration parameters that you
may find useful.
SUMMARY STEPS
1. enable
2. configure terminal
3. interface tunnel tunnel-number
4. Enter one of the following commands:
• ipv6 address {ipv6-address/prefix-length | prefix-name sub-bits/prefix-length}
• ipv6 address ipv6-prefix/prefix-length [eui-64]
DETAILED STEPS
Example:
Device# configure terminal
Step 3 interface tunnel tunnel-number Specifies a tunnel interface and number, and enters interface
configuration mode.
Example:
Device(config)# interface tunnel 0
Step 5 tunnel source {ip-address | interface-type Specifies the source IPv4 address or the source interface type and
interface-number} number for the tunnel interface.
• If an interface is specified, the interface must be configured
Example: with an IPv4 address.
Device(config-if)# tunnel source
gigabitethernet 0/0/0
Step 6 tunnel destination ip-address Specifies the destination IPv4 address or hostname for the tunnel
interface.
Example:
Device(config-if)# tunnel destination
192.168.30.1
Example:
Device(config-if)# end
Router A Configuration
interface ethernet 0
ip address 192.168.99.1 255.255.255.0
interface tunnel 0
ipv6 address 3ffe:b00:c18:1::3/127
tunnel source ethernet 0
tunnel destination 192.168.30.1
tunnel mode ipv6ip
Router B Configuration
interface ethernet 0
ip address 192.168.30.1 255.255.255.0
interface tunnel 0
ipv6 address 3ffe:b00:c18:1::2/127
tunnel source ethernet 0
tunnel destination 192.168.99.1
tunnel mode ipv6ip
!
ipv6 unicast-routing
ipv6 cef
!
interface Ethernet0/0
no ip address
ipv6 address 2001:DB8:2:1::1/64
no shutdown
exit
!
!
ipv6 route 2001:DB8:2:2::/64 2001:DB8:2:1::2
ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:1::2
!
ipv6 unicast-routing
ipv6 cef
!
interface Tunnel0
no ip address
ipv6 address 2001:DB8:2:4::1/64
tunnel source 10.22.22.22
tunnel destination 10.44.44.44
exit
!
interface Ethernet0/0
no ip address
ipv6 address 2001:DB8:2:1::2/64
no shutdown
exit
!
interface Ethernet1/1
no ip address
ip address 10.22.22.22 255.255.255.0
no shutdown
exit
!
ip route 10.44.44.0 255.255.255.0 10.22.22.23
ipv6 route 2001:DB8:2:2::/64 Tunnel0 2001:DB8:2:4::2
!
ipv6 unicast-routing
ipv6 cef
!
interface Tunnel0
no ipv6 address
ipv6 address 2001:DB8:2:4::2/64
tunnel source 10.44.44.44
tunnel destination 10.22.22.22
exit
!
interface Ethernet0/0 no ipv6 address
ipv6 address 2001:DB8:2:2::1/64
no shutdown
exit
!
interface Ethernet1/0
no ip address
ip address 10.44.44.44 255.255.255.0
no shutdown
exit
!
ip route 10.22.22.0 255.255.255.0 10.44.44.43
!
ipv6 route 2001:DB8:2:1::/64 Tunnel0 2001:DB8:2:4::1
!
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Ethernet0/0
no ipv6 address
ipv6 address 2001:DB8:2:2::2/64
no shutdown
exit
!
!
ipv6 route 2001:DB8:2:1::/64 2001:DB8:2:2::1
ipv6 route 2001:DB8:2:4::/64 2001:DB8:2:2::1
!
interface Ethernet1/0
no ip address
ip address 10.44.44.43 255.255.255.0
no shutdown
exit
!
interface Ethernet1/1
no ip address
ip address 10.22.22.23 255.255.255.0
no shutdown
exit
!
From PE1
Device# show tunnel interface
Tunnel0
Mode:GRE/IP, Destination 10.44.44.44, Source 10.22.22.22
IP transport: output interface Ethernet1/1 next hop 10.22.22.23
Application ID 1: unspecified
Linestate - current up
Internal linestate - current up, evaluated up
Tunnel Source Flags: Local
Transport IPv4 Header DF bit cleared
OCE: IP tunnel decap
Provider: interface Tu0, prot 47
Performs protocol check [47]
Protocol Handler: GRE: opt 0x0
ptype: ipv4 [ipv4 dispatcher: punt]
ptype: ipv6 [ipv6 dispatcher: from if Tu0]
ptype: mpls [mpls dispatcher: drop]
ptype: otv [mpls dispatcher: drop]
ptype: generic [mpls dispatcher: drop]
There are 0 tunnels running over the EON IP protocol
There are 0 tunnels running over the IPinIP protocol
There are 0 tunnels running over the NOSIP protocol
There are 0 tunnels running over the IPv6inIP protocol
There are 0 tunnels running over the RBSCP/IP protocol
Additional References
Related Documents
Standard/RFC Title
RFCs for IPv6 IPv6 RFCs
MIBs
Technical Assistance
Description Link
The Cisco Support and Documentation website http://www.cisco.com/cisco/web/support/index.html
provides online resources to download documentation,
software, and tools. Use these resources to install and
configure the software and to troubleshoot and resolve
technical issues with Cisco products and technologies.
Access to most tools on the Cisco Support and
Documentation website requires a Cisco.com user ID
and password.
Table 3: Feature Information for Manually Configured IPv6 over IPv4 Tunnels