0% found this document useful (0 votes)
31 views

7-CEF LAB Time

The document describes configurations and tests performed on routers R1, R2 and R3 to verify different fast forwarding mechanisms. Interface and routing configurations are shown for each router. Commands are then listed to test Cisco Express Forwarding (CEF) using packet debugging, verify fast switching by disabling CEF, and test fast processing by disabling fast switching on interfaces. The purpose is to observe forwarding operations and validate whether packets hit the routing table or are switched using cached entries.

Uploaded by

Daniel Cafu
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
0% found this document useful (0 votes)
31 views

7-CEF LAB Time

The document describes configurations and tests performed on routers R1, R2 and R3 to verify different fast forwarding mechanisms. Interface and routing configurations are shown for each router. Commands are then listed to test Cisco Express Forwarding (CEF) using packet debugging, verify fast switching by disabling CEF, and test fast processing by disabling fast switching on interfaces. The purpose is to observe forwarding operations and validate whether packets hit the routing table or are switched using cached entries.

Uploaded by

Daniel Cafu
Copyright
© © All Rights Reserved
Available Formats
Download as PDF, TXT or read online on Scribd
You are on page 1/ 3

LAB Time:

R1 Configuration
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.12.2
R2 Configuration
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#ip route 3.3.3.0 255.255.255.0 192.168.23.3
R2(config)#ip route 33.33.33.0 255.255.255.0 192.168.23.3
R3 Configuration
R3(config)#interface fastEthernet 1/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback3
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#exit
R3(config)#interface loopback33
R3(config-if)#ip address 33.33.33.33 255.255.255.0
R3(config-if)#exit
R3(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.2

1 | P a g e Created by Ahmad Ali E-Mail: [email protected] , Mobile: 056 430 3717


CEF Verification
Commands Description
R2#debug ip packet Enable packet debug on Router 2
R1#ping 192.168.23.3 Ping from R1 to R3 interface

Let’s check there is no debug output every packet is going through FIB table hardware.

Fast Switching Verification


Commands Description
R2(config)#no ip cef Disable CEF on Router 2
R1#ping 192.168.23.3 Ping from R1 to R3 interface

Only first packet hit RIB (Routing Information Base) CPU, rest of all packets cache.

Let’s verify Fast Switching Cache table.

Fast Processing Verification


Commands Description
R2(config)#interface f0/0 Enter interface mode
R2(config-if)#no ip route-cache Disable Fast Switching on interface
R2(config-if)#exit Exit from interface mode
R2(config)#interface f1/0 Enter interface mode
R2(config-if)#no ip route-cache Disable Fast Switching on interface
R1#ping 192.168.23.3 Ping from R1 to R3 interface

2 | P a g e Created by Ahmad Ali E-Mail: [email protected] , Mobile: 056 430 3717


Let’s verify, every single packet is hitting RIB(Routing Information Base) means control Plan.

Fast Switching is disable there is no entry in table.

3 | P a g e Created by Ahmad Ali E-Mail: [email protected] , Mobile: 056 430 3717

You might also like