MODUL 3 - Creating An Interconnected IP Network

Download as pdf or txt
Download as pdf or txt
You are on page 1of 28

MODUL JARINGAN KOMPUTER

INFORMATIKA
UNIVERSITAS MULAWARMAN

Creating an Interconnected IP Network


I. INTRODUCTION

Setelah Praktikum ini mahasiswa di harapkan dapat :

1) Learn how to configure an IPv4 address on an interface


2) Understand the functions and meanings of loopback interfaces
3) Understand how direct routes are generated
4) Learn how to configure static routes and understand the conditions for the
static routes to take effect
5) Learn how to test the connectivity of the network layer by using the ping
tool
6) Learn how to configure static routes and understand their application
scenarios

II. IPV4

Internet Protocol version 4 (IPv4) is a core protocol of the TCP/IP protocol suite and
works at the Internet layer in the TCP/IP model or the network layer in the Open System
Interconnection (OSI) model. The network layer provides connectionless data transmission.
Each IP datagram is transmitted independently, removing the need to establish a connection
before IP datagrams are sent.

III. NETWORKING TOPOLOGY

JARINGAN KOMPUTER / INFORMATIKA UNMUL 1


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

Network topology is the arrangement of the elements (links, nodes, etc.) of a


communication network. Network topology can be used to define or describe the
arrangement of various types of telecommunication networks, including command and control
radio networks,industrial fieldbusses and computer networks.

Network topology is the topological structure of a network and may be depicted physically
or logically. It is an application of graph theory wherein communicating devices are modeled
as nodes and the connections between the devices are modeled as links or lines between the
nodes. Physical topology is the placement of the various components of a network (e.g., device
location and cable installation), while logical topology illustrates how data flows within a
network. Distances between nodes, physical interconnections, transmission rates, or signal
types may differ between two different networks, yet their logical topologies may be identical.
A network’s physical topology is a particular concern of the physical layer of the OSI model.

R1, R2, and R3 are gateways of their networks. You need to configure these gateways to
connect these networks.

IV. LAB CONFIGURATION

Step1 Complete basic device configuration.

# Name the devices.

The details are not provided here.

Step2 Display the IP address of the current interface and the routing table of the router.

JARINGAN KOMPUTER / INFORMATIKA UNMUL 2


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

# Display the interface status on the router (R1 in this example).

[R1]display ip interface brief


*down: administratively down
^down: standby
(l): loopback
(s): spoofing
(E): E-Trunk down
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 5
The number of interface that is UP in Protocol is 1
The number of interface that is DOWN in Protocol is 10

Interface IP Address/Mask Physical Protocol


GigabitEthernet0/0/1 unassigned up down
GigabitEthernet0/0/2 unassigned up down
GigabitEthernet0/0/3 unassigned up down
The display ip interface brief command displays the brief information about interface
addresses, including the IP addresses, subnet masks, physical status, link-layer protocol
status, and number of interfaces in different states.

GigabitEthernet0/0/1 and GigabitEthernet0/0/3 on R1 are not configured with IP addresses.


Therefore, the IP Address/Mask field is in the unassigned state, the Protocol field is in
the down state, and the Physical field is in the up state.

# Display the routing table on the router (R1 in this example).

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 4 Routes : 4

Destination/Mask Proto Pre Cost Flags NextHop Interface

127.0.0.0/8 Direct 0 0 D
127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D
127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D
127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D
127.0.0.1 InLoopBack0

JARINGAN KOMPUTER / INFORMATIKA UNMUL 3


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

InLoopBack0 is a default loopback interface.

InLoopBack0 uses the fixed loopback address 127.0.0.1/8 to receive data packets destined
for the host where InLoopBack0 resides. The IP address of the InLoopBack0 interface
cannot be changed or advertised using a routing protocol.

Step3 Configure IP addresses for physical interfaces.

# Configure IP addresses for physical interfaces based on the following table.

IP addresses of physical interfaces

Router Interface IP Address/Mask

R1 GigabitEthernet0/0/1 10.0.13.1/24

GigabitEthernet0/0/3 10.0.12.1/24

R2 GigabitEthernet0/0/3 10.0.12.2/24

GigabitEthernet0/0/4 10.0.23.2/24

R3 GigabitEthernet0/0/1 10.0.13.3/24

GigabitEthernet0/0/3 10.0.23.3/24

<R1>system-view
[R1]interface GigabitEthernet0/0/1
[R1-GigabitEthernet0/0/1]ip address 10.0.13.1 24
[R1-GigabitEthernet0/0/1]quit
[R1]interface GigabitEthernet0/0/3
[R1-GigabitEthernet0/0/3]ip address 10.0.12.1 24
[R1-GigabitEthernet0/0/3]quit

<R2>system-view
[R2]interface GigabitEthernet0/0/3
[R2-GigabitEthernet0/0/3]ip address 10.0.12.2 24
[R2-GigabitEthernet0/0/3]quit
[R2]interface GigabitEthernet0/0/4
[R2-GigabitEthernet0/0/4]ip address 10.0.23.2 24
[R2-GigabitEthernet0/0/4]quit

JARINGAN KOMPUTER / INFORMATIKA UNMUL 4


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

<R3>system-view
[R3]interface GigabitEthernet0/0/1
[R3-GigabitEthernet0/0/1]ip address 10.0.13.3 24
[R3-GigabitEthernet0/0/1]quit
[R3]interface GigabitEthernet0/0/3
[R3-GigabitEthernet0/0/3]ip address 10.0.23.3 24
[R3-GigabitEthernet0/0/3]quit

# Use the ping tool to test the connectivity.

[R1]ping 10.0.12.2
PING 10.0.12.2: 56 data bytes, press CTRL_C to break
Reply from 10.0.12.2: bytes=56 Sequence=1 ttl=255 time=70 ms
Reply from 10.0.12.2: bytes=56 Sequence=2 ttl=255 time=50 ms
Reply from 10.0.12.2: bytes=56 Sequence=3 ttl=255 time=40 ms
Reply from 10.0.12.2: bytes=56 Sequence=4 ttl=255 time=30 ms
Reply from 10.0.12.2: bytes=56 Sequence=5 ttl=255 time=50 ms

--- 10.0.12.2 ping statistics ---


5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 30/48/70 ms

[R1]ping 10.0.13.3
PING 10.0.13.3: 56 data bytes, press CTRL_C to break
Reply from 10.0.13.3: bytes=56 Sequence=1 ttl=255 time=50 ms
Reply from 10.0.13.3: bytes=56 Sequence=2 ttl=255 time=60 ms
Reply from 10.0.13.3: bytes=56 Sequence=3 ttl=255 time=50 ms
Reply from 10.0.13.3: bytes=56 Sequence=4 ttl=255 time=30 ms
Reply from 10.0.13.3: bytes=56 Sequence=5 ttl=255 time=30 ms

--- 10.0.13.3 ping statistics ---


5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 30/44/60 ms

# Display the routing table of R1.

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 10 Routes : 10

JARINGAN KOMPUTER / INFORMATIKA UNMUL 5


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.12.0/24 Direct
0 0 D 10.0.12.1 GigabitEthernet0/0/3
10.0.12.1/32 Direct
0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct
0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.13.0/24 Direct
0 0 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.1/32 Direct
0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct
0 0 D 127.0.0.1 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0

The preceding command output shows that three direct routes are automatically generated
for each interface after the IP addresses of the interfaces are configured, which are

1. A route to the network where the interface resides

2. The host route to the interface

3. The host route to the broadcast address of the network where the
interface resides

A host route is a route with a 32-bit mask.

Step2 Create a loopback interface.

# Configure the loopback interface according to the following table.

IP addresses of loopback interfaces

JARINGAN KOMPUTER / INFORMATIKA UNMUL 6


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

Router Interface IP Address/Mask

R1 LoopBack0 10.0.1.1/32

R2 LoopBack0 10.0.1.2/32

R3 LoopBack0 10.0.1.3/32

Loopback interfaces are logical interfaces manually configured and do not exist physically.
Logical interfaces can be used to exchange data. A loopback interface is always Up at
the physical layer and link layer unless it is manually shut down. Generally, a loopback
interface uses a 32-bit mask. Loopback interfaces are used for the following purposes:

1. Used as the address for identifying and managing the router

2. Used as the router ID in OSPF

3. Used for improving network reliability

In this lab activity, the loopback interfaces are used to simulate clients.

[R1]interface LoopBack0
[R1-LoopBack0]ip address 10.0.1.1 32
[R2]interface LoopBack0
[R2-LoopBack0]ip address 10.0.1.2 32
[R3]interface LoopBack0
[R3-LoopBack0]ip address 10.0.1.3 32
# Display the routing table on the router (R1 in this example).

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 11 Routes : 11

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0


10.0.12.0/24 Direct 0 0 D 10.0.12.1 GigabitEthernet0/0/3
10.0.12.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3

JARINGAN KOMPUTER / INFORMATIKA UNMUL 7


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

10.0.13.0/24 Direct 0 0 D 10.0.13.1 GigabitEthernet0/0/1


10.0.13.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
Direct routes have been generated.

# Test the connectivity between the loopback interfaces.

[R1]ping -a 10.0.1.1 10.0.1.2


PING 10.0.1.2: 56 data bytes, press CTRL_C to break
Request time out
Request time out
Request time out
Request time out
Request time out

--- 10.0.1.2 ping statistics ---


5 packet(s) transmitted
0 packet(s) received
100.00% packet loss
Using the ping –a source-ip-address destination-ip-address command to specify the source and
destination IP addresses of ping packets. At this point, the router does not have a
route to the destination IP address. Therefore, the ping operation fails.

Step2 Configure static routes.

# On R1, configure a route to the loopback0 interfaces of R2 and R3.

[R1]ip route-static 10.0.1.2 32 10.0.12.2


[R1]ip route-static 10.0.1.3 32 10.0.13.3
# Display the routing table of R1.

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 13 Routes : 13

Destination/Mask Proto Pre Cost Flags NextHop Interface

JARINGAN KOMPUTER / INFORMATIKA UNMUL 8


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0


10.0.1.2/32 Static 60 0 RD 10.0.12.2 GigabitEthernet0/0/3
10.0.1.3/32 Static 60 0 RD 10.0.13.3 GigabitEthernet0/0/1
10.0.12.0/24 Direct 0 0 D 10.0.12.1 GigabitEthernet0/0/3
10.0.12.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.13.0/24 Direct 0 0 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
The configured static routes are added to the IP routing table.

# Test connectivity.

[R1]ping -a 10.0.1.1 10.0.1.2


PING 10.0.1.2: 56 data bytes, press CTRL_C to break
Request time out
Request time out
Request time out
Request time out
Request time out

--- 10.0.1.2 ping statistics ---


5 packet(s) transmitted
0 packet(s) received
100.00% packet loss
The loopback0 interface of R2 still cannot be pinged because R2 does not have a route to
the loopback0 interface of R1.
# On R2, add a route to LoopBack0 of R1.

[R2]ip route-static 10.0.1.1 32 10.0.12.1

# Test connectivity.

<R1>ping -a 10.0.1.1 10.0.1.2


PING 10.0.1.2: 56 data bytes, press CTRL_C to break
Reply from 10.0.1.2: bytes=56 Sequence=1 ttl=255 time=60 ms
Reply from 10.0.1.2: bytes=56 Sequence=2 ttl=255 time=30 ms
Reply from 10.0.1.2: bytes=56 Sequence=3 ttl=255 time=10 ms
Reply from 10.0.1.2: bytes=56 Sequence=4 ttl=255 time=50 ms
Reply from 10.0.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms

JARINGAN KOMPUTER / INFORMATIKA UNMUL 9


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

--- 10.0.1.2 ping statistics ---


5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 10/36/60 ms
Loopback0 on R1 can communicate with loopback0 on R2.

# Configure other necessary routes.

[R2]ip route-static 10.0.1.3 32 10.0.23.3


[R3]ip route-static 10.0.1.1 32 10.0.13.1
[R3]ip route-static 10.0.1.2 32 10.0.23.2
# Test the connectivity between the loopback0 interfaces of the routers by referring to the
proceeding description.

Step3 Configure a path from R1 to R2 via R3 as the backup path from LoopBack0 of R1 to
LoopBack0 of R2.

# Configure static routes on R1 and R2.

[R1]ip route-static 10.0.1.2 32 10.0.13.3 preference 100


[R2]ip route-static 10.0.1.1 32 10.0.23.3 preference 100
# Display the routing tables of R1 and R2.

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 13 Routes : 13

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0


10.0.1.2/32 Static 60 0 RD 10.0.12.2 GigabitEthernet0/0/3
10.0.1.3/32 Static 60 0 RD 10.0.13.3 GigabitEthernet0/0/1
10.0.12.0/24 Direct 0 0 D 10.0.12.1 GigabitEthernet0/0/3
10.0.12.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.13.0/24 Direct 0 0 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

JARINGAN KOMPUTER / INFORMATIKA UNMUL 10


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0


255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0

[R2]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 13 Routes : 13

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Static 60 0 RD 10.0.12.1 GigabitEthernet0/0/3


10.0.1.2/32 Direct 0 0 D 127.0.0.1 LoopBack0
10.0.1.3/32 Static 60 0 RD 10.0.23.3 GigabitEthernet0/0/4
10.0.12.0/24 Direct 0 0 D 10.0.12.2 GigabitEthernet0/0/3
10.0.12.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.23.0/24 Direct 0 0 D 10.0.23.2 GigabitEthernet0/0/4
10.0.23.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/4
10.0.23.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/4
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
The static route with a preference value of 100 is not added to the routing table.

# Shut down GigabitEthernet0/0/3 interface on R1 and R2 to invalidate the route with the
highest priority.

[R1]interface GigabitEthernet0/0/3
[R1-GigabitEthernet0/0/3]shutdown
# Display the routing table on R1 and R2. The command output shows that the routes with
a lower priority are activated when the routes with a higher priority are invalidated.

[R1]display IP routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 10 Routes : 10

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0


10.0.1.2/32 Static 100 0 RD 10.0.13.3 GigabitEthernet0/0/1

JARINGAN KOMPUTER / INFORMATIKA UNMUL 11


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

10.0.1.3/32 Static 60 0 RD 10.0.13.3 GigabitEthernet0/0/1


10.0.13.0/24 Direct 0 0 D 10.0.13.1
GigabitEthernet0/0/1
10.0.13.1/32 Direct 0 0 D 127.0.0.1
GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1
GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0

[R2]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 10 Routes : 10

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Static 100 0 RD 10.0.23.3 GigabitEthernet0/0/4


10.0.1.2/32 Direct 0 0 D 127.0.0.1 LoopBack0
10.0.1.3/32 Static 60 0 RD 10.0.23.3 GigabitEthernet0/0/4
10.0.23.0/24 Direct 0 0 D 10.0.23.2 GigabitEthernet0/0/4
10.0.23.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/4
10.0.23.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/4
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
In this case, the original static route becomes invalid and the static route with a lower
priority is activated.

# Test connectivity.

[R1]ping -a 10.0.1.1 10.0.1.2


PING 10.0.1.2: 56 data bytes, press CTRL_C to break
Reply from 10.0.1.2: bytes=56 Sequence=1 ttl=254 time=80 ms
Reply from 10.0.1.2: bytes=56 Sequence=2 ttl=254 time=60 ms
Reply from 10.0.1.2: bytes=56 Sequence=3 ttl=254 time=60 ms
Reply from 10.0.1.2: bytes=56 Sequence=4 ttl=254 time=110 ms
Reply from 10.0.1.2: bytes=56 Sequence=5 ttl=254 time=80 ms

--- 10.0.1.2 ping statistics ---

JARINGAN KOMPUTER / INFORMATIKA UNMUL 12


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 60/78/110 ms
# Trace the path of the data packets.

[R1]tracert -a 10.0.1.1 10.0.1.2

traceroute to 10.0.1.2(10.0.1.2), max hops: 30 ,packet length: 40,press CTRL_C to break

1 10.0.13.3 40 ms 30 ms 50 ms

2 10.0.23.2 80 ms 80 ms 60 ms
The tracert command displays the path of packets from the source to the destination.

The command output shows that the data packets pass through GigabitEthernet0/0/1 and
GigabitEthernet0/0/3 of R3 and are then forwarded to GigabitEthernet0/0/4 of R2.

In some lab environments, the devices may not respond to ICMP packets for security
reasons. Therefore, the results may vary. You can press Ctrl+C to end the tracert
operation.

Step4 Configure default routes to connect the LoopBack0 interface of R1 and the
LoopBack0 interface of R2.

# Restore the interfaces and delete the configured routes.

[R1]interface GigabitEthernet0/0/3
[R1-GigabitEthernet0/0/3]undo shutdown
[R1-GigabitEthernet0/0/3]quit
[R1]undo ip route-static 10.0.1.2 255.255.255.255 10.0.12.2
[R1]undo ip route-static 10.0.1.2 255.255.255.255 10.0.13.3 preference 100

# Display the routing table of R1.

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------

JARINGAN KOMPUTER / INFORMATIKA UNMUL 13


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

Routing Tables: Public


Destinations : 12 Routes : 12

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0


10.0.1.3/32 Static 60 0 RD 10.0.13.3 GigabitEthernet0/0/1
10.0.12.0/24 Direct 0 0 D 10.0.12.1 GigabitEthernet0/0/3
10.0.12.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.13.0/24 Direct 0 0 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
R1 does not have a route to LoopBack0 (10.1.1.2/32) of R2.

# Configure a default route on R1.

[R1]ip route-static 0.0.0.0 0 10.0.12.2

# Display the routing table of R1.

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 13 Routes : 13

Destination/Mask Proto Pre Cost Flags NextHop Interface

Verification
You can run the ping and tracert commands to test the connectivity between loopback0
interfaces on
0.0.0.0/0 Static 60 0 RD 10.0.12.2 GigabitEthernet0/0/3

0.0.0.0/0 Static 60 0 RD 10.0.12.2 GigabitEthernet0/0/3


10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0
10.0.1.3/32 Static 60 0 RD 10.0.13.3 GigabitEthernet0/0/1
10.0.12.0/24 Direct 0 0 D 10.0.12.1 GigabitEthernet0/0/3

JARINGAN KOMPUTER / INFORMATIKA UNMUL 14


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

10.0.12.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3


10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.13.0/24 Direct 0 0 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
The default route has been activated.

# Test the connectivity between LoopBack0 of R1 and LoopBack0 of R2.

[R1]ping -a 10.0.1.1 10.0.1.2


PING 10.0.1.2: 56 data bytes, press CTRL_C to break
Reply from 10.0.1.2: bytes=56 Sequence=1 ttl=255 time=50 ms
Reply from 10.0.1.2: bytes=56 Sequence=2 ttl=255 time=30 ms
Reply from 10.0.1.2: bytes=56 Sequence=3 ttl=255 time=20 ms
Reply from 10.0.1.2: bytes=56 Sequence=4 ttl=255 time=40 ms
Reply from 10.0.1.2: bytes=56 Sequence=5 ttl=255 time=20 ms

--- 10.0.1.2 ping statistics ---


5 packet(s) transmitted
5 packet(s) received
0.00% packet loss
round-trip min/avg/max = 20/32/50 ms
LoopBack0 of R1 can communicate with LoopBack0 of R2.

----End

different devices.

Configuration Reference
Configuration on R1

#
sysname R1
#
interface GigabitEthernet0/0/1
ip address 10.0.13.1 255.255.255.0
#
interface GigabitEthernet0/0/3

JARINGAN KOMPUTER / INFORMATIKA UNMUL 15


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

ip address 10.0.12.1 255.255.255.0


#
interface LoopBack0
ip address 10.0.1.1 255.255.255.255
#
ip route-static 0.0.0.0 0.0.0.0 10.0.12.2
ip route-static 10.0.1.3 255.255.255.255 10.0.13.3
#
return
Configuration on R2

#
sysname R2
#
interface GigabitEthernet0/0/3
ip address 10.0.12.2 255.255.255.0
#
interface GigabitEthernet0/0/4
ip address 10.0.23.2 255.255.255.0
#
interface LoopBack0
ip address 10.0.1.2 255.255.255.255
#
ip route-static 10.0.1.1 255.255.255.255 10.0.12.1
ip route-static 10.0.1.1 255.255.255.255 10.0.23.3 preference 100
ip route-static 10.0.1.3 255.255.255.255 10.0.23.3
#
return
Configuration on R3

#
sysname R3
#
interface GigabitEthernet0/0/1
ip address 10.0.13.3 255.255.255.0
#
interface GigabitEthernet00/3
ip address 10.0.23.3 255.255.255.0
#
interface LoopBack0
ip address 10.0.1.3 255.255.255.255
#
ip route-static 10.0.1.1 255.255.255.255 10.0.13.1
ip route-static 10.0.1.2 255.255.255.255 10.0.23.2
#

JARINGAN KOMPUTER / INFORMATIKA UNMUL 16


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

return

V. OSPF ROUTING

OSPF stands for Open Shortest Path First, which is an IGRP (Interior Gateway
Routing Protocol) type routing protocol that can only operate or work within a company or
organization's internal network.

What is meant by the internal network here is a network where you still have full
privilege to use, manage or modify it. In other words, you still have administration rights in
the network. If you no longer have the right to set up or modify the network, then the
network is no longer categorized as an internal network, but is categorized as an external
network.

In addition, OSPF is also an open standard routing protocol. That is, this OSPF was not
created by any vendor. That way, anyone can use it, any device can be compatible with it,
and it can be implemented anywhere.

VI. LAB CONFIGURATION

Configuration Roadmap
1. Create OSPF processes on the devices and enable OSPF on the interfaces.

2. Configure OSPF authentication.

3. Configure OSPF to advertise default routes.

4. Control OSPF route selection using costs.

Configuration Procedure
Step1 Complete basic device configuration.

JARINGAN KOMPUTER / INFORMATIKA UNMUL 17


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

# Follow steps 1, 2, 3, and 4 in lab 1 to name the routers and configure the IP addresses of
the physical and loopback interfaces.

# Display the routing table on the router (R1 in this example).

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 11 Routes : 11

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0


10.0.12.0/24 Direct 0 0 D 10.0.12.1 GigabitEthernet0/0/3
10.0.12.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.13.0/24 Direct 0 0 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
At this point, only direct routes exist on the device.

Step2 Complete the basic OSPF configuration.

# Create an OSPF process.

[R1]ospf 1

You can set OSPF parameters only after creating an OSPF process. OSPF supports multiple
independent processes on one device. Route exchange between different OSPF
processes is similar to that between different routing protocols. You can specify a
process ID when creating an OSPF process. If no process ID is specified, the default
process ID 1 is used.

# Create an OSPF area and specify the interfaces on which OSPF is to be enabled.

[R1-ospf-1]area 0

The area command creates an OSPF area and displays the OSPF area view.

JARINGAN KOMPUTER / INFORMATIKA UNMUL 18


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

[R1-ospf-1-area-0.0.0.0]network 10.0.12.1 0.0.0.255


[R1-ospf-1-area-0.0.0.0]network 10.0.13.1 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 10.0.1.1 0.0.0.0
The network network-address wildcard-mask command specifies the interfaces on which
OSPF is to be enabled. OSPF can run on an interface only when the following two
conditions are met:

1. The mask length of the interface's IP address is not shorter than that specified in the
network command. OSPF uses reverse mask. For example 0.0.0.255 indicates that the
mask length is 24 bits.

2. The address of the interface must be within the network range specified in the network
command.

In this example, OSPF can be enabled on the three interfaces, and they are all added to area
0.

[R2]ospf
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 10.0.12.2 0.0.0.0
[R2-ospf-1-area-0.0.0.0]network 10.0.23.2 0.0.0.0
[R2-ospf-1-area-0.0.0.0]network 10.0.1.2 0.0.0.0
If the wildcard mask in the network command is all 0s and the IP address of the interface is
the same as the IP address specified in the network-address command, the interface
also runs OSPF.

[R3]ospf
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]network 10.0.13.3 0.0.0.0
[R3-ospf-1-area-0.0.0.0]network 10.0.23.3 0.0.0.0
[R3-ospf-1-area-0.0.0.0]network 10.0.1.3 0.0.0.0
Step3 Display the OSPF status.

# Displays the OSPF neighbor information.

[R1]display ospf peer

OSPF Process 1 with Router ID 10.0.1.1


Neighbors

JARINGAN KOMPUTER / INFORMATIKA UNMUL 19


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

Area 0.0.0.0 interface 10.0.13.1(GigabitEthernet0/0/1)'s neighbors


Router ID: 10.0.1.3 Address: 10.0.13.3
State: Full Mode:Nbr is Master Priority: 1
DR: 10.0.13.3 BDR: 10.0.13.1 MTU: 0
Dead timer due in 36 sec
Retrans timer interval: 0
Neighbor is up for 00:00:30
Authentication Sequence: [ 0 ]

Neighbors

Area 0.0.0.0 interface 10.0.12.1(GigabitEthernet0/0/3)'s neighbors


Router ID: 10.0.1.2 Address: 10.0.12.2
State: Full Mode:Nbr is Master Priority: 1
DR: 10.0.12.2 BDR: 10.0.12.1 MTU: 0
Dead timer due in 39 sec
Retrans timer interval: 4
Neighbor is up for 00:00:28
Authentication Sequence: [ 0 ]
The display ospf peer command displays information about neighbors in each OSPF area.
The information includes the area to which the neighbor belongs, router ID of the
neighbor, neighbor status, DR, and BDR.

# Display the routes learned from OSPF.

[R1]display ip routing-table protocol ospf


Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : OSPF
Destinations : 3 Routes : 4

OSPF routing table status : <Active>


Destinations : 3 Routes : 4

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.2/32 OSPF 10 1 D 10.0.12.2 GigabitEthernet0/0/3


10.0.1.3/32 OSPF 10 1 D 10.0.13.3 GigabitEthernet0/0/1
10.0.23.0/24 OSPF 10 2 D 10.0.13.3 GigabitEthernet0/0/1
OSPF 10 2 D 10.0.12.2 GigabitEthernet0/0/3

OSPF routing table status : <Inactive>


Destinations : 0 Routes : 0
Step4 Configure OSPF authentication.

JARINGAN KOMPUTER / INFORMATIKA UNMUL 20


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

# Configure interface authentication on R1.

[R1]interface GigabitEthernet0/0/1
[R1- GigabitEthernet0/0/1]ospf authentication-mode md5 1 cipher HCIA-Datacom
[R1]interface GigabitEthernet0/0/3
[R1- GigabitEthernet0/0/3]ospf authentication-mode md5 1 cipher HCIA-Datacom
[R1- GigabitEthernet0/0/3]display this
#
interface GigabitEthernet0/0/3
ip address 10.0.12.1 255.255.255.0
ospf authentication-mode md5 1 cipher foCQTYsq-4.A\^38y!DVwQ0#
#
The password is displayed in cipher text when you view the configuration because cipher
means cipher-text.

# Display OSPF neighbors.

[R1]display ospf peer brief

OSPF Process 1 with Router ID 10.0.1.1


Peer Statistic Information
-------------------------------------------------------------------------------------------------------------------
-----------
Area Id Interface Neighbor id State
-------------------------------------------------------------------------------------------------------------------
-----------
Total Peer(s): 0
Authentication is not configured on other routers. Therefore, the authentication fails and no
neighbor is available.

# Configuring interface authentication on R2.

[R2]interface GigabitEthernet0/0/3
[R2- GigabitEthernet0/0/3]ospf authentication-mode md5 1 cipher HCIA-Datacom
[R2]interface GigabitEthernet0/0/4
[R2- GigabitEthernet0/0/4]ospf authentication-mode md5 1 cipher HCIA-Datacom
# Display OSPF neighbors on R2.
[R2]display ospf peer brief

OSPF Process 1 with Router ID 10.0.1.2


Peer Statistic Information
-------------------------------------------------------------------------------------------------------------------
-----------

JARINGAN KOMPUTER / INFORMATIKA UNMUL 21


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

Area Id Interface Neighbor id State


0.0.0.0 GigabitEthernet0/0/3 10.0.1.1 Full
-------------------------------------------------------------------------------------------------------------------
-----------
Total Peer(s): 1
R2 has established a neighbor relationship with R1.

# Configure area authentication on R3.

[R3]ospf
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]authentication-mode md5 1 cipher HCIA-Datacom
# Display OSPF neighbors on R3.

[R3]display ospf peer brief

OSPF Process 1 with Router ID 10.0.1.3


Peer Statistic Information
--------------------------------------------------------------------------------------------------------------------
------------
Area Id Interface Neighbor id State
0.0.0.0 GigabitEthernet0/0/1 10.0.1.1 Full
0.0.0.0 GigabitEthernet0/0/3 10.0.1.2 Full
--------------------------------------------------------------------------------------------------------------------
------------
Total Peer(s): 2
R3 has established a neighbor relationship with R1 and R2. Note: OSPF interface authentication and
area authentication implement OSPF packet authentication on OSPF interfaces.

Step5 Assume that R1 is the egress of all networks. Therefore, R1 advertises the default
route to OSPF.

# Advertise the default route on R1.

[R1]ospf
[R1-ospf-1]default-route-advertise always
The default-route-advertise command advertises the default route to a common OSPF
area. If the always argument is not specified, the default route is advertised to other
routers only when there are active non-OSPF default routes in the routing table of the
local router. In this example, no default route exists in the local routing table. Therefore,
the always argument needs to be used.

JARINGAN KOMPUTER / INFORMATIKA UNMUL 22


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

# Display the IP routing tables of R2 and R3.

[R2]display ip routing-table
Route Flags: R - relay, D - download to fib
--------------------------------------------------------------------------------------------------------------------
----
Routing Tables: Public
Destinations : 15 Routes : 16

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 10.0.12.1


GigabitEthernet0/0/3
10.0.1.1/32 OSPF 10 1 D 10.0.12.1
GigabitEthernet0/0/3
10.0.1.2/32 Direct 0 0 D 127.0.0.1 LoopBack0
10.0.1.3/32 OSPF 10 1 D 10.0.23.3
GigabitEthernet0/0/4
10.0.12.0/24 Direct 0 0 D 10.0.12.2
GigabitEthernet0/0/3
10.0.12.2/32 Direct 0 0 D 127.0.0.1
GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1
GigabitEthernet0/0/3
10.0.13.0/24 OSPF 10 2 D 10.0.12.1
GigabitEthernet0/0/3
OSPF 10 2 D 10.0.23.3 GigabitEthernet0/0/4
10.0.23.0/24 Direct 0 0 D 10.0.23.2
GigabitEthernet0/0/4
10.0.23.2/32 Direct 0 0 D 127.0.0.1
GigabitEthernet0/0/4
10.0.23.255/32 Direct 0 0 D 127.0.0.1
GigabitEthernet0/0/4
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0

[R3]display ip routing-table
Route Flags: R - relay, D - download to fib
--------------------------------------------------------------------------------------------------------------------
----
Routing Tables: Public
Destinations : 15 Routes : 16

JARINGAN KOMPUTER / INFORMATIKA UNMUL 23


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 10.0.13.1 GigabitEthernet0/0/1


10.0.1.1/32 OSPF 10 1 D 10.0.13.1 GigabitEthernet0/0/1
10.0.1.2/32 OSPF 10 1 D 10.0.23.2 GigabitEthernet0/0/3
10.0.1.3/32 Direct 0 0 D 127.0.0.1 LoopBack0
10.0.12.0/24 OSPF 10 2 D 10.0.23.2 GigabitEthernet0/0/3
OSPF 10 2 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.0/24 Direct 0 0 D 10.0.13.3 GigabitEthernet0/0/1
10.0.13.3/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.23.0/24 Direct 0 0 D 10.0.23.3 GigabitEthernet0/0/3
10.0.23.3/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.23.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
R2 and R3 have learned the default route.

Step6 Change the cost values of interfaces on R1 so that LoopBack0 on R1 can reach
LoopBack0 on R2 via R3.

# According to the routing table of R1, the cost of the route from R1 to LoopBack0 of R2 is
1, and the cost of the route from R1 to R2 via R3 is 2. Therefore, you only need to
change the cost of the route from R1 to LoopBack0 of R2 to ensure that the value is
greater than 2.

[R1]interface GigabitEthernet0/0/3
[R1- GigabitEthernet0/0/3]ospf cost 10
# Display the routing table of R1.

[R1]display ip routing-table
Route Flags: R - relay, D - download to fib
--------------------------------------------------------------------------------------------------------------------
------------
Routing Tables: Public
Destinations : 14 Routes : 14

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.1.1/32 Direct 0 0 D 127.0.0.1 LoopBack0

JARINGAN KOMPUTER / INFORMATIKA UNMUL 24


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

10.0.1.2/32 OSPF 10 2 D 10.0.13.3


GigabitEthernet0/0/1
10.0.1.3/32 OSPF 10 1 D 10.0.13.3 GigabitEthernet0/0/1
10.0.12.0/24 Direct 0 0 D 10.0.12.1 GigabitEthernet0/0/3
10.0.12.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.12.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/3
10.0.13.0/24 Direct 0 0 D 10.0.13.1 GigabitEthernet0/0/1
10.0.13.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.13.255/32 Direct 0 0 D 127.0.0.1 GigabitEthernet0/0/1
10.0.23.0/24 OSPF 10 2 D 10.0.13.3 GigabitEthernet0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
127.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
255.255.255.255/32 Direct 0 0 D 127.0.0.1 InLoopBack0
In this case, the next hop of the route from R1 to LoopBack0 on R2 is GigabitEthernet0/0/1 on R3.
# Verify the result by issuing Tracert commands.
[R1]tracert –a 10.0.1.1 10.0.1.2

traceroute to 10.0.1.2(10.0.1.2), max hops: 30 ,packet length: 40,press CTRL_C to break

1 10.0.13.3 40 ms 50 ms 50 ms

2 10.0.23.2 60 ms 110 ms 70 ms

----End

Verification
1. Test the connectivity between interfaces on different devices using Ping.

2. Shut down interfaces to simulate link faults and check the changes in routing tables.

Configuration Reference
Configuration on R1

#
sysname R1
#

JARINGAN KOMPUTER / INFORMATIKA UNMUL 25


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

interface GigabitEthernet0/0/1
ip address 10.0.13.1 255.255.255.0
ospf authentication-mode md5 1 cipher
%^%#`f*R'6q/RMq(+5*g(sP~SB8oQ49;%7WE:07P7X:W%^%#
#
interface GigabitEthernet0/0/3
ip address 10.0.12.1 255.255.255.0
ospf cost 10
ospf authentication-mode md5 1 cipher
%^%#]e)pBf~7B0.FM~U;bRAVgE$U>%X;>T\M\tLlYRj2%^%#
#
interface LoopBack0
ip address 10.0.1.1 255.255.255.255
#
ospf 1
default-route-advertise always
area 0.0.0.0
network 10.0.1.1 0.0.0.0
network 10.0.12.0 0.0.0.255
network 10.0.13.0 0.0.0.255
#
return
Configuration on R2
#
sysname R2
#
interface GigabitEthernet0/0/3
ip address 10.0.12.2 255.255.255.0
ospf authentication-mode md5 1 cipher
%^%#z+72ZaTk2+v/g7E~AmR"NFYAKC>LZ8~Y`[**Gh=&%^%#
#
interface GigabitEthernet0/0/4
ip address 10.0.23.2 255.255.255.0
ospf authentication-mode md5 1 cipher %^%#=@2jEBu!{&UYoB*(RDVLc5t~<1B_a-
PwC$WH%jQ3%^%#
#
interface LoopBack0
ip address 10.0.1.2 255.255.255.255
#
ospf 1
area 0.0.0.0
network 10.0.1.2 0.0.0.0
network 10.0.12.2 0.0.0.0
network 10.0.23.2 0.0.0.0
#

JARINGAN KOMPUTER / INFORMATIKA UNMUL 26


MODUL JARINGAN KOMPUTER
INFORMATIKA
UNIVERSITAS MULAWARMAN

return
Configuration on R3

#
sysname R3
#
interface GigabitEthernet0/0/1
ip address 10.0.13.3 255.255.255.0
#
interface GigabitEthernet0/0/3
ip address 10.0.23.3 255.255.255.0
#
interface LoopBack0
ip address 10.0.1.3 255.255.255.255
#
ospf 1
area 0.0.0.0
authentication-mode md5 1 cipher %^%#Rl<:SVln1M>[Gk"v/OeSEW|:0:4*h;b|-
d:N"s{>%^%#
network 10.0.1.3 0.0.0.0
network 10.0.13.3 0.0.0.0
network 10.0.23.3 0.0.0.0
#
return

JARINGAN KOMPUTER / INFORMATIKA UNMUL 27

You might also like