Build A Switch and Router Network

Download as pdf or txt
Download as pdf or txt
You are on page 1of 6

Packet Tracer - Build a Switch and Router Network

​Addressing Table
Device Interface IP Address Subnet Mask Default Gateway

R1 G0/0/0 192.168.0.1 255.255.255.0 N/A

R1
G0/0/1 192.168.1.1 255.255.255.0 N/A

S1 VLAN 1 192.168.1.2 255.255.255.0 192.168.1.1


PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1

PC-B NIC 192.168.0.3 255.255.255.0 192.168.0.1


Blank Line, No additional information

​Objectives
Part 1: Configure Devices and Verify Connectivity
● Assign static IP information to the PC interfaces.
● Configure the router and switch.
● Verify network connectivity.
Part 2: Display Device Information
● Retrieve hardware and software information from the network devices.
● Interpret the output from the routing table.
● Display interface information on the router.
● Display a summary list of the interfaces on the router and switch.
Part 3: Secure Remote Access to the Router
● Set the IP domain name and generate secure keys.
● Create an SSH user and configure VTY lines for SSH-only access.
● Verify SSH Implementation.

​Background / Scenario
In this lab, you will cable the equipment and configure the devices to match the Addressing Table. After the
configurations have been saved, you will verify your configurations by testing for network connectivity.
After the devices have been configured and network connectivity has been verified, you will use IOS
commands to retrieve information from the devices to answer questions about your network equipment. You
will also access the router remotely via SSH.

© 2020 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 1 of 6 www.netacad.com
Packet Tracer - Build a Switch and Router Network

​Instructions

Part 1: Configure Devices and Verify Connectivity


In Part 1, you will set up the network topology and configure basic settings, such as the interface IP
addresses, device access, and passwords. Refer to the Addressing Table at the beginning of this activity for
device names and address information.

Step 1: Connect the devices.


The devices are already deployed in the workspace. You will connect them using the correct cables between
the devices as listed below:
● Connect PCA F0 to S1 F0/1.
● Connect S1 G0/1 to R1 G0/0/1.
● Connect R1 G0/0/0 to PCB F0.

Step 2: Assign static IP information to the PC interfaces.


a. Configure the IP address, subnet mask, and default gateway settings on PC-A.
b. Configure the IP address, subnet mask, and default gateway settings on PC-B.
c. Ping PC-B from a command prompt window on PC-A.
Question:

Why were the pings not successful?

The router interfaces, default gateways have not been configured yet so the traffic is not
being routed between subnets.
Type your answers here.

Step 3: Configure R1.


Open configuration window

a. Console into the router and enable privileged EXEC mode. (Hint: Use console cable and terminal on a
PC)
b. Enter configuration mode.
c. Assign a device name to the router according to the Addressing Table.
d. Assign class as the privileged EXEC encrypted password.
e. Assign cisco as the console password and enable login.
f. Encrypt the plaintext passwords.
g. Create a banner that warns anyone accessing the device that unauthorized access is prohibited.
h. Configure the IP addresses according to the Addressing Table and activate both Ethernet interfaces on
the router.
interface GigabitEthernet0/0/0
R1(config)# interface GigabitEthernet0/0/0
R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface GigabitEthernet0/0/1
R1(config-if)# ip address 192.168.1.1 255.255.255.0

© 2020 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 2 of 6 www.netacad.com
Packet Tracer - Build a Switch and Router Network

R1(config-if)# no shutdown
i. Save the running configuration to the startup configuration file.
Question:

Were the pings successful? Explain.

Yes.The router is routing the ping traffic across the two subnets.The default setting for the
switch will automatically enable the interfaces that are connected to device
Type your answers here.

Step 4: Configure S1.


Note: Most of the commands on the switch are similar to the commands on the router in this step. Use the
help (?) context as necessary.
Open configuration window

a. Console into the switch and enable privileged EXEC mode.


b. Enter configuration mode.
c. Assign a device name to the switch according to the Addressing Table.
d. Assign class as the privileged EXEC encrypted password.
e. Assign cisco as the console password and enable login.
f. Encrypt the plaintext passwords.
g. Create a banner that warns anyone accessing the device that unauthorized access is prohibited.
h. Configure the IP address for the SVI for VLAN 1 according to the Addressing Table and activate the
interface.
i. Configure the default gateway according to the Addressing Table.
j. Save the running configuration to the startup configuration file.

Part 2: Display Device Information

Step 1: Retrieve hardware and software information from the network devices.
a. Use the show version command to answer the following questions about the router.
R1# show version
Question:

What is the name of the IOS image that the router is running?
Cisco IOS Xe software version 03.16.05.s extended support release
Cisco IOS software , ISR software(X86_64_Linux_IOSD-..............
version 15.5(3) S5 Release software Ofc2)
Technical support:
http//www.cisco.com/techsupport
copyright ….

yur answers here.

© 2020 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 3 of 6 www.netacad.com
Packet Tracer - Build a Switch and Router Network

b. Use the show version command to answer the following questions about the switch.
S1# show version
Cisco IOS Software C2960 Software (C2960- Lanbase-M),Version …..
Software (fc) Copyright by Cisco System, Inc
ROM:C2960 Boot Loader (c2960-HBOOT-M)..........
Questions:

What is IOS software image and version running on the switch?


Software image is c2960-lanbase-m and software version is 12.2….
Type your answers here.
What is the model number of the switch?
WS-C2960-24TT
Type your answers here.

Step 2: Display the routing table on the router.


Use the show ip route command on the router to answer the following questions.
R1# show ip route
Gateway of last resort is not set
192.168.0.0/24 is veriably subnetted,2 subnets ,2 masks
C 192.168.0.0/24 is directly connected gigabitEthernet0/0/0
L 192.168.0.1/32 is directly connected,gigbitethrnet0/0/0
192.168.1.0/24 is veriably subnetted 2 subnets 2 mask
C 192.168.1.0/24 is directly connected gigabitethernet0/0/1
L 192.168.1.1/32 is directly connected,gigabitethet0/0/1
Questions:

What code is used in the routing table to indicate a directly connected network?
The C designates a directly connected network.An L designates a local interface. Type your answers here.
How many route entries are coded with a C code in the routing table?
2 Type your answers here.
What interface types are associated to the C coded routes?
G0/0/0 and G0/0/1 Type your answers here.

Step 3: Display interface information on the router.


Use the show interface g0/0/1 to answer the following questions.
R1# show interfaces g0/0/1
Questions:

What is the operational status of the G0/0/1 interface?


G0/0/1 is up, line protocol is up (connected)
Internet address is 192.168.1.1/24
MTU 1500 BW 100000 Kbit, DLY 10 usec reliability 255/255,txload 1/255, rxload
1/255 Encapsulation ARPA , ARP Timeout 04:00:00 Last input …….
Out put hang never
Last clearing of “show interface” counters never…………..

© 2020 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 4 of 6 www.netacad.com
Packet Tracer - Build a Switch and Router Network

ype your answers here.


What is the Media Access Control (MAC) address of the G0/01 interface?
MAC address will appear in the form of:xxxx.xxxx.xxxx, where each x will be replaced with
hexadecimal number,it is 00d0.bcaa.5702 Type your answers here.
How is the Internet address displayed in this command?
Internet address is 192.168.1.1/24
Type your answers here.

Step 4: Display a summary list of the interfaces on the router and switch.
There are several commands that can be used to verify an interface configuration. One of the most useful of
these is the show ip interface brief command. The command output displays a summary list of the
interfaces on the device and provides immediate feedback to the status of each interface.
a. Enter the show ip interface brief command on the router.
R1# show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 192.168.0.1 YES NVRAM up up
GigabitEthernet0/0/1 192.168.1.1 YES NVRAM up up
Vlan1 unassigned YES NVRAM administratively down down

b. Enter the show ip interface brief command on the switch.


S1# show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 unassigned YES unset down down
FastEthernet0/2 unassigned YES unset down down
<output omitted>
GigabitEthernet0/1 unassigned YES unset up up
GigabitEthernet0/2 unassigned YES unset down down
Vlan1 192.168.1.2 YES manual up up
Close configuration window

Part 3: Secure Remote Access to the Router

Step 1: Set the IP domain name and generate secure keys.


a. On R1, configure the domain name as academy.net.
R1(config)# ip domain-name academy.net
b. Generate RSA keys with a 1024 key length.
R1(config)# crypto key generate rsa
The name for the keys will be: R1.academy.net
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024


% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

© 2020 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 5 of 6 www.netacad.com
Packet Tracer - Build a Switch and Router Network

Step 2: Create an SSH user and configure VTY lines for SSH-only access.
a. Create a user with SSHuser as the username and cisco as the secret password.
R1(config)# username SSHuser secret cisco
b. Configure the VTY lines to use the local username database for login credentials.
R1(config)# line vty 0 4
R1(config-line)# login local
c. The VTY lines should only allow SSH for remote access.
R1(config-line)# transport input ssh
Close configuration window

Step 3: Verify SSH Implementation.


a. Click PCA, select Command Prompt in the Desktop tab.
b. At the prompt, enter ssh -l SSHuser 192.168.1.1.
c. Enter cisco when prompted for the password.
Question:

What is the displayed message?


The configured banner MOTD id displayed
Type your answers here.
You should be at the prompt of R1. If you are not successful, verify the configurations are correct and the
credentials were entered correctly.

​Reflection
1. If the G0/0/1 interface showed administratively down, what interface configuration command would you use to
turn the interface up?
R1(config-if)# no shutdownType your answers here.
2. What would happen if you had incorrectly configured interface G0/0/1 on the router with an IP address of
192.168.1.2?
PC-A would not be able to ping PC-B .This is because PC-B on the different network than PC-A which
requires the default gateway router to route these packets.PC-A is configured to use the IP address of
192.168.1.1 for the default-gateway router.but this address is not assigned to any device on the LAN.
Any packets that need to be sent to the default-gateway for routing will never reach their destination.

Type your answers here.


End of document

© 2020 - 2022 Cisco and/or its affiliates. All rights reserved. Cisco Public Page 6 of 6 www.netacad.com

You might also like