Multi-Site VXLAN Lab With BGP EVPN
Multi-Site VXLAN Lab With BGP EVPN
Multi-Site VXLAN Lab With BGP EVPN
June 9, 2024
1. Overview
This lab is designed to explore complex multi-site VXLAN (Virtual
Extensible LAN) using EVE-NG. I will be providing you with sample
configurations and steps so that you can also setup and explore.
I used EVE-NG bare metal for this lab. The actual EVE-NG topology is quite
messy, and it is a good idea to create your own diagram with either Visio
or Draw.io. Then, you can map all the nodes with the diagram in EVE-NG
and accessed nodes by clicking on the nodes. Another reason why I prefer
EVE-NG is that it provides faster and easier packet capturing capabilities.
All of this information can be found at www.eve-ng.net. This lab can
consume significant amount of CPU and RAM. I will not get into details
about the requirements. I suggest you use Cisco documentation to figure
out the resources. It is also a good idea to throw more resources if you
can.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 1/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Note: The diagram that I posted here is somehow blurry. I believe it is the
limitation of the LinkedIn. You can download from here by my one-drive
link Multi-Site VxLan Lab with BGP EVPN.png.
Before we go deeper, I want to show you the packet capture from ISP-1
router interface Gi3.
As you can see in Figure 3, the traffic from Server 3 to Server 1 is passed
over VXLAN and you can clearly see the VXLAN headers. The standard
MTU size for Ethernet is 1500. Unless you use direct fiber cable between
two DCs or have some arrangements with ISPs, I believe it is impossible to
run jumbo frames between two DCs. Fort that reason, MTU of all the
network devices are adjusted to 1500 and the servers are set with MTU
1370 bytes. In this capture, L2 VNI-10000 is extended from DC 1 to DC 2.
This is a demonstration that the VXLAN over the Internet can work
properly. For production environment, you might consider using CloudSec
to securely encrypt the VXLAN. You can refer to Cisco documentation
about how CloudSec. We will not be exploring CloudSec in this lab.
I hope you have good understanding of BGP. At least you have good
understanding of how BGP works in normal Cisco routers so that you can
catch up with the Nexus and Palo Alto BGP configurations. I used the
following KVM images in this lab.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 2/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Palo Alto Firewalls - Palo Alto VM Firewalls KVM images
You should set up the identical lab and make VXLAN works in your own
lab. It is important to have hand-on experience so that you have clear
pictures of VXLAN configurations, and you can troubleshoot when
something does not work.
I also run vPC between all the Leaf Switch pairs. You should also disable
the links between two ToR switches if you encounter mac flapping as this
is not important for the purpose of learning VXLAN.
Data Center 1 is setup using Multi-AS Model with eBGP Underlay. This
model is better as you do not need to use any other routing protocol
rather than BGP. BGP is more stable and scalable as the network grows. All
routing devices are running their own AS in this model. During underlay
configuration eBGP peering is achieved using physical interface IP
addresses and it is used to advertise Loopback interfaces which will be
used for overlay eBGP peering used by VTEPs. For leaf switches running
vPC, it is important to advertise both primary and secondary loopback
addresses. vPC will not be functional without secondary loopback IP
address.
Data Center 2 is setup using a Single AS model with OSPF Underlay. OSPF
will be used to achieve underlay reachability. For overlay, we will use iBGP
and the spine switches will be configured as route reflectors. During data
center inter-connect, you may need to perform redistribution between
iBGP and OSPF so that we have full reachability between DC 1 and DC 2
loopback interfaces from Nexus Switches.
As for the VNIs, VNI 5000 is L2 VNI and which will terminate at the Palo
Alto Firewalls. VNI 15000 is L3 VNI on border leaf switches and both
switches can be configured using the same IP using Anycast Gateway. VNI
10000 is used for vMotion LAN, and the VXLAN fabric is extended from DC
1 to DC 2 via layer 3 core. This is to satisfy the vMotion requirements of L2
adjacency between two VMs.
If you want to learn more about VXLAN and EVPN, you can refer to RFC
7348 (Virtual eXtensible Local Area Network (VXLAN): A Framework for
Overlaying Virtualized Layer 2 Networks over Layer 3 Networks) and RFC
8365 (A Network Virtualization Overlay Solution Using Ethernet VPN
(EVPN)).
2. Underlay Configurations
The purpose of underlay network is to provide reachability between
loopback interfaces which will be used as source interface for VTEPs
(VXLAN Tunnel End Point). After completing the configuration of all the
switches, please make sure to test the reachability between loopback
interfaces.
hostname NX9K-Spine-1
!
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 3/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
feature bgp
!
system jumbomtu 1500
!
interface Ethernet1/1
description CONNECT-TO-NX9K-Leaf-1
ip address 10.0.0.1/30
no shutdown
!
interface Ethernet1/2
description CONNECT-TO-NX9K-Leaf-2
ip address 10.0.2.1/30
no shutdown
!
interface Ethernet1/3
description CONNECT-TO-Border-Leaf-1
ip address 10.0.4.1/30
no shutdown
!
interface Ethernet1/4
description CONNECT-TO-Border-Leaf-2
ip address 10.0.6.1/30
no shutdown
!
interface loopback0
ip address 1.1.1.1/32
!
router bgp 65501
router-id 1.1.1.1
address-family ipv4 unicast
network 1.1.1.1/32
!
neighbor 10.0.0.2
remote-as 64611
description BGP-Underlay-To-NX9K-Leaf-1
address-family ipv4 unicast
!
neighbor 10.0.2.2
remote-as 64622
description BGP-Underlay-To-NX9K-Leaf-2
address-family ipv4 unicast
!
neighbor 10.0.4.2
remote-as 64633
description BGP-Underlay-To-NX9K-Border-Leaf-1
address-family ipv4 unicast
!
neighbor 10.0.6.2
remote-as 64644
description BGP-Underlay-To-NX9K-Border-Leaf-2
address-family ipv4 unicast
hostname NX9K-Spine-2
!
feature bgp
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 4/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
system jumbomtu 1500
!
interface Ethernet1/1
description CONNECT-TO-NX9K-Leaf-2
ip address 10.0.3.1/30
no shutdown
!
interface Ethernet1/2
description CONNECT-TO-NX9K-Leaf-1
ip address 10.0.1.1/30
no shutdown
!
interface Ethernet1/3
description CONNECT-TO-Border-Leaf-2
ip address 10.0.7.1/30
no shutdown
!
interface Ethernet1/4
description CONNECT-TO-NX9K-Border-Leaf-1
ip address 10.0.5.1/30
no shutdown
!
interface loopback0
ip address 2.2.2.2/32
!
router bgp 65502
router-id 2.2.2.2
address-family ipv4 unicast
network 2.2.2.2/32
!
neighbor 10.0.1.2
remote-as 64611
description BGP-Underlay-To-NX9K-Leaf-1
address-family ipv4 unicast
!
neighbor 10.0.3.2
remote-as 64622
description BGP-Underlay-To-NX9K-Leaf-2
address-family ipv4 unicast
!
neighbor 10.0.5.2
remote-as 64633
description BGP-Underlay-To-NX9K-Border-Leaf-1
address-family ipv4 unicast
!
neighbor 10.0.7.2
remote-as 64644
description BGP-Underlay-To-NX9K-Border-Leaf-2
address-family ipv4 unicast
hostname NX9K-Leaf-1
!
feature bgp
feature lacp
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 5/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
feature vpc
feature interface-vlan
!
system jumbomtu 1500
!
vlan 1,500,1000
!
vlan 500
name DC-1-SERVER-TENANT
!
vlan 1000
name V-MOTION
!
vrf context VPC-KEEPALIVE
!
vpc domain 10
role priority 10
peer-keepalive destination 10.0.8.2 source
10.0.8.1 vrf VPC-KEEPALIVE
ip arp synchronize
!
interface Vlan500
description SERVER-TENANT
no shutdown
!
interface Vlan1000
description V-MOTION
no shutdown
!
interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
spanning-tree port type network
vpc peer-link
!
interface Ethernet1/1
description CONNECT-TO-NX9K-Spine-1
no switchport
ip address 10.0.0.2/30
no shutdown
!
interface Ethernet1/2
description CONNECT-TO-NX9K-Spine-2
no switchport
ip address 10.0.1.2/30
no shutdown
!
interface Ethernet1/3
description CONNECT-TO-F5-LTM-1
switchport access vlan 500
!
interface Ethernet1/4
description V-Motion
switchport mode trunk
switchport trunk allowed vlan 1000
!
interface Ethernet1/29
description VPC-PEER-KEEPALIVE
no switchport
vrf member VPC-KEEPALIVE
ip address 10.0.8.1/30
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 6/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
no shutdown
!
interface Ethernet1/30
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
channel-group 10 mode active
!
interface Ethernet1/31
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
channel-group 10 mode active
!
interface loopback0
ip address 11.11.11.11/32
ip address 1.0.0.1/32 secondary
!
# The secondary IP address of the Loopback0 must be
the same for vPC peer leaf switch.
!
router bgp 64611
router-id 11.11.11.11
address-family ipv4 unicast
network 1.0.0.1/32
network 11.11.11.11/32
!
neighbor 10.0.0.1
remote-as 65501
description BGP-Underlay-To-NX9K-Spine-1
address-family ipv4 unicast
!
neighbor 10.0.1.1
remote-as 65502
description BGP-Underlay-To-NX9K-Spine-2
address-family ipv4 unicast
hostname NX9K-Leaf-2
!
feature bgp
feature interface-vlan
feature lacp
feature vpc
!
system jumbomtu 1500
!
vlan 1,500,1000
!
vlan 500
name DC-1-SERVER-TENANT
!
vlan 1000
name V-MOTION
!
vrf context VPC-KEEPALIVE
!
vpc domain 10
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 7/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
role priority 10
peer-keepalive destination 10.0.8.1 source
10.0.8.2 vrf VPC-KEEPALIVE
ip arp synchronize
!
interface Vlan500
description SERVER-TENANT
no shutdown
!
interface Vlan1000
description V-MOTION
no shutdown
!
interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
spanning-tree port type network
vpc peer-link
!
interface Ethernet1/1
description CONNECT-TO-NX9K-Spine-2
no switchport
ip address 10.0.3.2/30
no shutdown
interface Ethernet1/2
description CONNECT-TO-NX9K-Spine-1
no switchport
ip address 10.0.2.2/30
no shutdown
interface Ethernet1/3
description CONNECT-TO-F5-LTM-2
switchport access vlan 500
interface Ethernet1/4
description V-Motion
switchport mode trunk
switchport trunk allowed vlan 1000
!
interface Ethernet1/29
description VPC-PEER-KEEPALIVE
no switchport
vrf member VPC-KEEPALIVE
ip address 10.0.8.2/30
no shutdown
!
interface Ethernet1/30
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
channel-group 10 mode active
!
interface Ethernet1/31
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
channel-group 10 mode active
!
interface loopback0
ip address 22.22.22.22/32
ip address 1.0.0.1/32 secondary
!
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 8/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
# The secondary IP address of the Loopback0 must be
the same for vPC peer leaf switch.
!
router bgp 64622
router-id 22.22.22.22
address-family ipv4 unicast
network 1.0.0.1/32
network 22.22.22.22/32
!
neighbor 10.0.2.1
remote-as 65501
description BGP-Underlay-To-NX9K-Spine-1
address-family ipv4 unicast
!
neighbor 10.0.3.1
remote-as 65502
description BGP-Underlay-To-NX9K-Spine-2
address-family ipv4 unicast
hostname NX9K-Border-Leaf-1
!
feature lacp
feature vpc
feature interface-vlan
feature bgp
!
system jumbomtu 1500
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
vlan 1,10,126,150,500
!
vlan 10
name DC-INTERCONNECT
!
vlan 126
name LINK-L3-VNI-TO-PA-FW
!
vn-segment 12600
vlan 150
name DC-1-Developer-Network
!
vlan 500
name DC-1-SERVER-TENANT
!
vrf context VPC-KEEPALIVE
!
vpc domain 10
role priority 10
peer-keepalive destination 10.0.8.2 source
10.0.8.1 vrf VPC-KEEPALIVE
ip arp synchronize
!
interface Vlan10
description DC-INTERCONNECT
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 9/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
no shutdown
ip address 10.0.30.3/29
!
interface Vlan126
description LINK-L3-VNI-TO-PA-FW
no shutdown
vrf member L3-VNI-LINK-TO-PA-FW
!
interface Vlan150
no shutdown
vrf member DC-1-Developer-Network
!
interface Vlan500
description SERVER-TENANT
no shutdown
ip forward
!
interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
spanning-tree port type network
vpc peer-link
!
interface Ethernet1/1
description CONNECT-TO-PA-FW-1
switchport mode trunk
interface Ethernet1/2
description CONNECT-TO-PA-FW-2
switchport mode trunk
interface Ethernet1/3
description CONNECT-TO-NX9K-Spine-1
no switchport
ip address 10.0.4.2/30
no shutdown
!
interface Ethernet1/4
description CONNECT-TO-NX9K-Spine-2
no switchport
ip address 10.0.5.2/30
no shutdown
!
interface Ethernet1/29
description VPC-PEER-KEEPALIVE
no switchport
vrf member VPC-KEEPALIVE
ip address 10.0.8.1/30
no shutdown
!
interface Ethernet1/30
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
interface Ethernet1/31
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
!
interface loopback0
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 10/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
ip address 33.33.33.33/32
ip address 1.0.0.3/32 secondary
!
# The secondary IP address of the Loopback0 must be
the same for vPC peer leaf switch.
!
router bgp 64633
router-id 33.33.33.33
address-family ipv4 unicast
network 1.0.0.3/32
network 33.33.33.33/32
!
neighbor 10.0.4.1
remote-as 65501
description BGP-Underlay-To-NX9K-Spine-1
address-family ipv4 unicast
!
neighbor 10.0.5.1
remote-as 65502
description BGP-Underlay-To-NX9K-Spine-2
address-family ipv4 unicast
!
neighbor 10.0.30.1
remote-as 64512
description PEERING-TO-PA-FW
address-family ipv4 unicast
hostname NX9K-Border-Leaf-2
!
feature lacp
feature vpc
feature interface-vlan
feature bgp
!
system jumbomtu 1500
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
vlan 1,10,126,150,500
!
vlan 10
name DC-INTERCONNECT
!
vlan 126
name LINK-L3-VNI-TO-PA-FW
!
vn-segment 12600
vlan 150
name DC-1-Developer-Network
!
vlan 500
name DC-1-SERVER-TENANT
!
vrf context VPC-KEEPALIVE
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 11/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
vpc domain 10
role priority 10
peer-keepalive destination 10.0.8.1 source
10.0.8.2 vrf VPC-KEEPALIVE
ip arp synchronize
!
interface Vlan10
description DC-INTERCONNECT
no shutdown
ip address 10.0.30.4/29
!
interface Vlan126
description LINK-L3-VNI-TO-PA-FW
no shutdown
!
interface Vlan150
no shutdown
!
interface Vlan500
description SERVER-TENANT
no shutdown
ip forward
!
interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
spanning-tree port type network
vpc peer-link
!
interface Ethernet1/1
description CONNECT-TO-PA-FW-2
switchport mode trunk
!
interface Ethernet1/2
description CONNECT-TO-PA-FW-1
switchport mode trunk
!
interface Ethernet1/3
description CONNECT-TO-NX9K-Spine-2
no switchport
ip address 10.0.7.2/30
no shutdown
!
interface Ethernet1/4
description CONNECT-TO-NX9K-Spine-1
no switchport
ip address 10.0.6.2/30
no shutdown
!
interface Ethernet1/29
description VPC-PEER-KEEPALIVE
no switchport
vrf member VPC-KEEPALIVE
ip address 10.0.8.2/30
no shutdown
!
interface Ethernet1/30
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 12/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
interface Ethernet1/31
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
!
interface loopback0
ip address 44.44.44.44/32
ip address 1.0.0.3/32 secondary
!
# The secondary IP address of the Loopback0 must be
the same for vPC peer leaf switch.
!
router bgp 64644
router-id 44.44.44.44
address-family ipv4 unicast
network 1.0.0.3/32
network 44.44.44.44/32
!
neighbor 10.0.6.1
remote-as 65501
description BGP-Underlay-To-NX9K-Spine-1
address-family ipv4 unicast
neighbor 10.0.7.1
remote-as 65502
description BGP-Underlay-To-NX9K-Spine-2
address-family ipv4 unicast
neighbor 10.0.30.1
remote-as 64512
description PEERING-TO-PA-FW
address-family ipv4 unicast
PA-FW-1&2 HA Configuration
I will briefly provide the Palo Alto firewall configuration with screen shots.
If you are familiar with Palo Alto firewall configuration, it should be easy
for you to setup by looking at the screenshots. The first step is to
configure HA for both firewall since the firewalls will be running Active-
Passive mode. In the production environment using physical firewall, you
might want to do Active-Active Cluster with vPC port channel.
Unfortunately, the port-channel feature is not supported for Palo Alto VM
series firewalls. As the first step of HA configuration set the HA interfaces
as you can see in Figure 3.
Then, configure the basic HA Pair Settings for each firewall as shown in
Figure 4. Refer to the IP addressing from the Figure 1 Topology and Use
"1" for PA-FW-1 and "2" for PA-FW-2.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 13/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
The next step will be configuring Control Links. Make sure you use the
right IP address for each firewall.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 14/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Figure 6 - HA Status
The next step will be configuring the Layer 2 VLAN. There are four ways
you can configure VLANs in Palo Alto firewalls. Here, we will use the L2
VLANs with L3 VLAN Interfaces.
Figure 7 - HA Status
You can map here with the L2 VLANs that you configured in the previous
steps at the VLAN tab.
You might also want to create zones and assigned the L3 interfaces in the
right zones.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 15/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Figure 10 - L3 Zones
Since we are just testing VXLAN here, I am going to allow all the traffic.
You might want to configure more secure rules in the production
environment. Remember, the first step is not to troubleshoot firewall rules,
but to get the VXLAN working. Then, you can tidy up the rules later on.
Figure 11 - ALLOW-ALL-Rule
We will create a new "Virtual Router" called "VxLAN-LAB" and all the
interfaces will be assigned to this virtual router.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 16/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Palo Alto BGP configuration is also the same as you would configure on a
Cisco Router.
We configure BGP neighbors at the Peer Group tab in Palo Alto. It is just
the GUI
This is pretty much the same concept with normal Cisco switch BGP
configuration and if you understand Cisco switch BGP configuration, you
know what it is going on here.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 17/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 18/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
WAN-R-1 Configuration
hostname WAN-R-1
!
vrf definition ISP-1
rd 64613:1
!
address-family ipv4
exit-address-family
!
vrf definition ISP-2
rd 64613:2
!
address-family ipv4
exit-address-family
!
interface GigabitEthernet1
description CONNECT-TO-PA-FW-E1/3
vrf forwarding ISP-1
ip address 172.0.0.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet2
description CONNECT-TO-PA-FW-E1/4
vrf forwarding ISP-2
ip address 172.0.1.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet3
vrf forwarding ISP-1
ip address 121.1.33.2 255.255.255.252
negotiation auto
!
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 19/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
interface GigabitEthernet4
vrf forwarding ISP-2
ip address 121.1.44.2 255.255.255.252
negotiation auto
!
router bgp 64513
bgp router-id 13.13.13.13
bgp log-neighbor-changes
!
address-family ipv4 vrf ISP-1
neighbor 121.1.33.1 remote-as 1000
neighbor 121.1.33.1 activate
neighbor 172.0.0.2 remote-as 64512
neighbor 172.0.0.2 activate
neighbor 172.0.0.2 default-originate
exit-address-family
!
address-family ipv4 vrf ISP-2
neighbor 121.1.44.1 remote-as 2000
neighbor 121.1.44.1 activate
neighbor 172.0.1.2 remote-as 64512
neighbor 172.0.1.2 activate
neighbor 172.0.1.2 default-originate
exit-address-family
WAN-R-2 Configuration
hostname WAN-R-2
!
boot-start-marker
boot-end-marker
!
!
vrf definition ISP-1
rd 64613:1
!
address-family ipv4
exit-address-family
!
vrf definition ISP-2
rd 64613:2
!
address-family ipv4
exit-address-family
!
interface GigabitEthernet1
description CONNECT-TO-PA-FW-E1/3
vrf forwarding ISP-1
ip address 172.0.0.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet2
description CONNECT-TO-PA-FW-E1/4
vrf forwarding ISP-2
ip address 172.0.1.1 255.255.255.252
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 20/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
negotiation auto
!
interface GigabitEthernet3
vrf forwarding ISP-2
ip address 121.2.33.2 255.255.255.252
negotiation auto
!
interface GigabitEthernet4
vrf forwarding ISP-1
ip address 121.2.44.2 255.255.255.252
negotiation auto
!
router bgp 64513
bgp router-id 13.13.13.13
bgp log-neighbor-changes
!
address-family ipv4 vrf ISP-1
neighbor 121.2.44.1 remote-as 1000
neighbor 121.2.44.1 activate
neighbor 172.0.0.2 remote-as 64512
neighbor 172.0.0.2 activate
neighbor 172.0.0.2 default-originate
exit-address-family
!
address-family ipv4 vrf ISP-2
neighbor 121.2.33.1 remote-as 2000
neighbor 121.2.33.1 activate
neighbor 172.0.1.2 remote-as 64512
neighbor 172.0.1.2 activate
neighbor 172.0.1.2 default-originate
exit-address-family
Server-1 Configuration
hostname Server-1
!
interface GigabitEthernet0/0
mtu 1370
ip address 192.168.22.10 255.255.255.0
no shutdown
!
enable secret Secure123
!
username admin privilege 15 secret Secure123
!
ip route 0.0.0.0 0.0.0.0 192.168.22.1
!
line vty 0 4
login local
transport input telnet
Server-2 Configuration
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 21/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
hostname Server-2
!
interface GigabitEthernet0/0
mtu 1370
ip address 192.168.22.20 255.255.255.0
no shutdown
!
enable secret Secure123
!
username admin privilege 15 secret Secure123
!
ip route 0.0.0.0 0.0.0.0 192.168.22.1
!
line vty 0 4
login local
transport input telnet
ToR-SW-1 Configuration
hostname ToR-SW-1
!
vlan 1000
name VMotion-LAN
!
interface GigabitEthernet0/0
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet0/3
switchport trunk allowed vlan 1000
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
ToR-SW-2 Configuration
hostname ToR-SW-2
!
vlan 1000
name VMotion-LAN
!
interface GigabitEthernet0/0
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet0/1
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 22/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
shutdown
!
interface GigabitEthernet0/2
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet0/3
switchport trunk allowed vlan 1000
switchport trunk encapsulation dot1q
switchport mode trunk
negotiation auto
You can follow the initial F5 setup wizard to activate trial license, setup HA,
and configure internal and external interfaces. For IP addressing, you can
refer to the initial topology. This is pretty straight forward. Adding F5 to
this VXLAN Lab is just for fun. I will not add more detail as the lab is too
much already. I will create a new article about F5 LTM configuration with
more step-by-step details in the future.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 23/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 24/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 25/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Once, the F5 has been successfully setup, you can try to access the servers
using virtual server IP address. Since, we are running quite a lot of Nexus
switches, the response may be slow sometimes.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 26/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Figure 31 - Accessing Servers using F5 Virtual IP address To Test Load Balancing from
Developer-PC-1
hostname NX9K-Spine-3
!
feature ospf
!
system jumbomtu 1500
!
interface Ethernet1/1
description CONNECT-TO-NX9K-Leaf-4
ip address 10.0.20.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/2
description CONNECT-TO-NX9K-Leaf-3
ip address 10.0.18.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/3
description CONNECT-TO-NX9K-Border-Leaf-3
ip address 10.0.14.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/4
description CONNECT-TO-NX9K-Border-Leaf-4
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 27/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
ip address 10.0.16.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface loopback0
ip address 3.3.3.3/32
ip router ospf 1 area 0.0.0.0
!
router ospf 1
hostname NX9K-Spine-4
!
feature ospf
!
system jumbomtu 1500
!
interface Ethernet1/1
description CONNECT-TO-NX9K-Leaf-3
ip address 10.0.19.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
interface Ethernet1/2
description CONNECT-TO-NX9K-Leaf-4
ip address 10.0.21.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
interface Ethernet1/3
description CONNECT-TO-Border-Leaf-4
ip address 10.0.17.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
interface Ethernet1/4
description CONNECT-TO-Border-Leaf-3
ip address 10.0.15.1/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface loopback0
ip address 4.4.4.4/32
ip router ospf 1 area 0.0.0.0
!
router ospf 1
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 28/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
hostname NX9K-Border-Leaf-3
!
feature ospf
feature interface-vlan
feature lacp
feature vpc
!
system jumbomtu 1500
!
vlan 1,10,126,150,500,1000
!
vlan 126
name LINK-L3-VNI-TO-PA-FW
!
vlan 150
name DC-1-Developer-Network
!
vlan 500
name DC-1-SERVER-TENANT
!
vlan 1000
name V-MOTION
!
vrf context VPC-KEEPALIVE
!
vpc domain 10
role priority 10
peer-keepalive destination 10.0.22.2 source
10.0.22.1 vrf VPC-KEEPALIVE
ip arp synchronize
!
interface Vlan10
description DC-INTERCONNECT
no shutdown
no ip redirects
ip address 10.0.31.2/29
ip router ospf 1 area 0.0.0.0
!
interface Vlan126
description LINK-L3-VNI-TO-PA-FW
no shutdown
!
interface Vlan150
description DC-1-Developer-Network
no shutdown
!
interface Vlan500
description SERVER-TENANT
no shutdown
!
interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
spanning-tree port type network
vpc peer-link
!
interface Ethernet1/1
description CONNECT-TO-PA-FW
switchport mode trunk
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 29/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
switchport trunk allowed vlan 10,126,500
!
interface Ethernet1/2
description CONNECT-TO-PA-FW
switchport mode trunk
switchport trunk allowed vlan 10,126,500
!
interface Ethernet1/3
description CONNECT-TO-NX9K-Spine-4
no switchport
ip address 10.0.17.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
interface Ethernet1/4
description CONNECT-TO-NX9K-Spine-3
no switchport
ip address 10.0.16.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/29
no switchport
vrf member VPC-KEEPALIVE
ip address 10.0.22.2/30
no shutdown
!
interface Ethernet1/30
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
!
interface Ethernet1/31
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
!
interface loopback0
ip address 66.66.66.66/32
ip address 1.0.0.56/32 secondary
ip router ospf 1 area 0.0.0.0
!
router ospf 1
hostname NX9K-Border-Leaf-3
!
feature ospf
feature interface-vlan
feature lacp
feature vpc
!
system jumbomtu 1500
!
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 30/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
vlan 1,10,126,150,500,1000
!
vlan 126
name LINK-L3-VNI-TO-PA-FW
!
vlan 150
name DC-1-Developer-Network
!
vlan 500
name DC-1-SERVER-TENANT
!
vlan 1000
name V-MOTION
!
vrf context VPC-KEEPALIVE
!
vpc domain 10
role priority 10
peer-keepalive destination 10.0.22.2 source
10.0.22.1 vrf VPC-KEEPALIVE
ip arp synchronize
!
interface Vlan10
description DC-INTERCONNECT
no shutdown
no ip redirects
ip address 10.0.31.2/29
ip router ospf 1 area 0.0.0.0
!
interface Vlan126
description LINK-L3-VNI-TO-PA-FW
no shutdown
!
interface Vlan150
description DC-1-Developer-Network
no shutdown
!
interface Vlan500
description SERVER-TENANT
no shutdown
!
interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
spanning-tree port type network
vpc peer-link
!
interface Ethernet1/1
description CONNECT-TO-PA-FW
switchport mode trunk
switchport trunk allowed vlan 10,126,500
!
interface Ethernet1/2
description CONNECT-TO-PA-FW
switchport mode trunk
switchport trunk allowed vlan 10,126,500
!
interface Ethernet1/3
description CONNECT-TO-NX9K-Spine-3
no switchport
ip address 10.0.14.2/30
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 31/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/4
description CONNECT-TO-NX9K-Spine-4
no switchport
ip address 10.0.15.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/10
description CONNECT-TO-DEVELOPER-PC-2
switchport access vlan 150
!
interface Ethernet1/29
no switchport
vrf member VPC-KEEPALIVE
ip address 10.0.22.1/30
no shutdown
!
interface Ethernet1/30
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
!
interface Ethernet1/31
switchport mode trunk
switchport trunk allowed vlan 1,10,126,150,500
channel-group 10 mode active
!
interface loopback0
ip address 55.55.55.55/32
ip address 1.0.0.56/32 secondary
ip router ospf 1 area 0.0.0.0
!
router ospf 1
hostname NX9k-Leaf-3
!
feature ospf
feature interface-vlan
feature lacp
feature vpc
!
system jumbomtu 1500
!
vlan 1,500,1000
!
vlan 500
name DC-1-SERVER-TENANT
!
vlan 1000
name V-MOTION
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 32/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
vrf context VPC-KEEPALIVE
!
vpc domain 10
role priority 10
peer-keepalive destination 10.0.23.2 source
10.0.23.1 vrf VPC-KEEPALIVE
ip arp synchronize
!
interface Vlan500
description SERVER-TENANT
no shutdown
!
interface Vlan1000
description V-MOTION
no shutdown
!
interface port-channel10
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
spanning-tree port type network
vpc peer-link
!
interface Ethernet1/1
description CONNECT-TO-NX9K-Spine-4
no switchport
ip address 10.0.19.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/2
description CONNECT-TO-NX9K-Spine-3
no switchport
ip address 10.0.18.2/30
ip ospf network point-to-point
ip router ospf 1 area 0.0.0.0
no shutdown
!
interface Ethernet1/3
description CONNECT-TO-F5-LTM-3
switchport access vlan 500
!
interface Ethernet1/4
description V-Motion
switchport mode trunk
switchport trunk allowed vlan 1000
!
interface Ethernet1/29
no switchport
vrf member VPC-KEEPALIVE
ip address 10.0.23.1/30
no shutdown
!
interface Ethernet1/30
switchport mode trunk
switchport trunk allowed vlan 1,500,1000
channel-group 10 mode active
!
interface Ethernet1/31
switchport mode trunk
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 33/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
switchport trunk allowed vlan 1,500,1000
channel-group 10 mode active
!
interface loopback0
ip address 77.77.77.77/32
ip address 1.0.0.34/32 secondary
ip router ospf 1 area 0.0.0.0
!
router ospf 1
Since we have already seen how to configure from GUI, we will use CLI
here.
#Both PA-FW-3&4
set deviceconfig system dns-setting servers primary
192.168.1.168 secondary 8.8.8.8
set deviceconfig system domain ht.local
set deviceconfig system timezone America/New_York
set deviceconfig system ntp-servers primary-ntp-
server ntp-server-address pool.ntp.org
!
set ethernet ethernet1/7 ha
set ethernet ethernet1/7 comment HA-1
set ethernet ethernet1/8 ha
set ethernet ethernet1/8 comment HA-1-BACKUP
set ethernet ethernet1/9 ha
set ethernet ethernet1/9 comment HA-2
set ethernet ethernet1/10 ha
set ethernet ethernet1/10 comment HA-2-BACKUP
# FOR PA-FW-3
set deviceconfig system hostname PA-FW-3
set deviceconfig high-availability enabled yes
set deviceconfig high-availability group mode
active-passive
set deviceconfig high-availability group group-id 10
set deviceconfig high-availability group description
HA-AP-Pair
set deviceconfig high-availability group peer-ip
10.0.24.2
set deviceconfig high-availability group peer-ip-
backup 10.0.25.2
set deviceconfig high-availability group election-
option device-priority 100
set deviceconfig high-availability group election-
option preemptive
set deviceconfig high-availability group election-
option heartbeat-backup yes
set deviceconfig high-availability group election-
option timers recommended
set deviceconfig high-availability group
configuration-synchronization enabled yes
set deviceconfig high-availability group state-
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 34/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
synchronization enabled yes transport ethernet ha2-
keep-alive enabled yes action log-only
!
set deviceconfig high-availability interface ha1
port ethernet1/3 ip-address 10.0.24.1 netmask
255.255.255.252
set deviceconfig high-availability interface ha1-
backup port ethernet1/4 ip-address 10.0.25.1 netmask
255.255.255.252
set deviceconfig high-availability interface ha2
port ethernet1/5 ip-address 10.0.26.1 netmask
255.255.255.252
set deviceconfig high-availability interface ha2-
backup port ethernet1/6 ip-address 10.0.27.1 netmask
255.255.255.252
# FOR PA-FW-4
set deviceconfig system hostname PA-FW-4
set deviceconfig high-availability enabled yes
set deviceconfig high-availability group mode
active-passive
set deviceconfig high-availability group group-id 10
set deviceconfig high-availability group description
HA-AP-Pair
set deviceconfig high-availability group peer-ip
10.0.24.1
set deviceconfig high-availability group peer-ip-
backup 10.0.25.1
set deviceconfig high-availability group election-
option device-priority 200
set deviceconfig high-availability group election-
option preemptive
set deviceconfig high-availability group election-
option heartbeat-backup yes
set deviceconfig high-availability group election-
option timers recommended
set deviceconfig high-availability group
configuration-synchronization enabled yes
set deviceconfig high-availability group state-
synchronization enabled yes transport ethernet ha2-
keep-alive enabled yes action log-only
!
set deviceconfig high-availability interface ha1
port ethernet1/3 ip-address 10.0.24.2 netmask
255.255.255.252
set deviceconfig high-availability interface ha1-
backup port ethernet1/4 ip-address 10.0.25.2 netmask
255.255.255.252
set deviceconfig high-availability interface ha2
port ethernet1/5 ip-address 10.0.26.2 netmask
255.255.255.252
set deviceconfig high-availability interface ha2-
backup port ethernet1/6 ip-address 10.0.27.2 netmask
255.255.255.252
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 35/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
# Configure Interfaces
set network interface ethernet ethernet1/1 comment
CONNECT-TO-N9K-Border-Leaf
!
set network interface ethernet ethernet1/1 layer2
units ethernet1/1.126 tag 126
!
set network interface ethernet ethernet1/1 layer2
units ethernet1/1.500 tag 500
!
set network interface ethernet ethernet1/1 layer2
units ethernet1/1.10 tag 10
set network interface ethernet ethernet1/1 layer2
units ethernet1/1.10 comment DC-INTERCONNECT
!
set network interface ethernet ethernet1/2 comment
CONNECT-TO-N9K-Border-Leaf
!
set network interface ethernet ethernet1/2 layer2
units ethernet1/2.126 tag 126
!
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 36/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
set network interface ethernet ethernet1/2 layer2
units ethernet1/2.500 tag 500
!
set network interface ethernet ethernet1/2 layer2
units ethernet1/2.10 tag 10
set network interface ethernet ethernet1/2 layer2
units ethernet1/2.10 comment DC-INTERCONNECT
!
set network interface ethernet ethernet1/3 comment
CONNECT-ISP-1&2
set network interface ethernet ethernet1/3 layer3 ip
172.0.2.2/30
set network interface ethernet ethernet1/3 layer3
interface-management-profile PING
!
set network interface ethernet ethernet1/4 layer3 ip
172.0.3.2/30
set network interface ethernet ethernet1/4 layer3
interface-management-profile PING
set network interface ethernet ethernet1/4 layer3
lldp enable no
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 37/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-1
reflector-client non-client
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2 peer-
address ip 172.0.3.1
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2
subsequent-address-family-identifier unicast yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2 local-
address ip 172.0.3.2/30
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2 local-
address interface ethernet1/4
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2 enable
yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2 peer-as
65000
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2 enable-
mp-bgp yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2 address-
family-identifier ipv4
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers peer WAN-R-VRF-ISP-2
reflector-client non-client
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers soft-reset-with-stored-info
yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group WAN-Routers enable yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches type ibgp export-
nexthop use-self
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
peer-address ip 10.0.31.2
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
subsequent-address-family-identifier unicast yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
local-address ip 10.0.31.1/29
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
local-address interface vlan.10
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
enable yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
peer-as 65000
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
enable-mp-bgp yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 38/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
address-family-identifier ipv4
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-3
reflector-client client
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
peer-address ip 10.0.31.3
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
subsequent-address-family-identifier unicast yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
local-address ip 10.0.31.1/29
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
local-address interface vlan.10
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
enable yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
peer-as 65000
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
enable-mp-bgp yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
address-family-identifier ipv4
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches peer Border-Leaf-4
reflector-client client
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches soft-reset-with-
stored-info yes
set network virtual-router VxLAN-LAB protocol bgp
peer-group Border-Leaf-Switches enable yes
set network virtual-router VxLAN-LAB protocol bgp
reject-default-route no
set network virtual-router VxLAN-LAB protocol bgp
allow-redist-default-route yes
set network virtual-router VxLAN-LAB protocol bgp
router-id 17.17.17.17
set network virtual-router VxLAN-LAB protocol bgp
local-as 65000
set network virtual-router VxLAN-LAB protocol bgp
install-route yes
set network virtual-router VxLAN-LAB protocol bgp
policy export rules Export-to-iBGP-Neighbor action
allow update nexthop 10.0.31.1
set network virtual-router VxLAN-LAB protocol bgp
policy export rules Export-to-iBGP-Neighbor match
route-table unicast
set network virtual-router VxLAN-LAB protocol bgp
policy export rules Export-to-iBGP-Neighbor used-by
Border-Leaf-Switches
set network virtual-router VxLAN-LAB protocol bgp
policy export rules Export-to-iBGP-Neighbor enable
yes
set network virtual-router VxLAN-LAB protocol bgp
policy export rules EXPORT-TO-WAN-Routers action
allow update nexthop 172.0.2.2
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 39/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
set network virtual-router VxLAN-LAB protocol bgp
policy export rules EXPORT-TO-WAN-Routers match
route-table unicast
set network virtual-router VxLAN-LAB protocol bgp
policy export rules EXPORT-TO-WAN-Routers used-by
WAN-Routers
set network virtual-router VxLAN-LAB protocol bgp
policy export rules EXPORT-TO-WAN-Routers enable yes
set network virtual-router VxLAN-LAB protocol bgp
redist-rules Red-Static address-family-identifier
ipv4
set network virtual-router VxLAN-LAB protocol bgp
redist-rules Red-Static enable yes
set network virtual-router VxLAN-LAB protocol bgp
redist-rules Red-Static set-origin igp
set network virtual-router VxLAN-LAB protocol bgp
redist-rules Red-Connected address-family-identifier
ipv4
set network virtual-router VxLAN-LAB protocol bgp
redist-rules Red-Connected enable yes
set network virtual-router VxLAN-LAB protocol bgp
redist-rules Red-Connected set-origin igp
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 40/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
30.200.200.0/24
set network virtual-router VxLAN-LAB routing-table
ip static-route VNI-15000 route-table unicast
commit
WAN-R-3 Configuration
hostname WAN-R-3
!
vrf definition ISP-1
rd 65000:1
!
address-family ipv4
exit-address-family
!
vrf definition ISP-2
rd 65000:2
!
address-family ipv4
exit-address-family
!
interface GigabitEthernet1
vrf forwarding ISP-1
ip address 172.0.2.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet2
vrf forwarding ISP-2
ip address 172.0.3.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet5
vrf forwarding ISP-1
ip address 121.13.55.2 255.255.255.252
negotiation auto
!
interface GigabitEthernet6
vrf forwarding ISP-2
ip address 121.23.66.2 255.255.255.252
negotiation auto
!
router bgp 65000
bgp router-id 15.15.15.15
bgp log-neighbor-changes
!
address-family ipv4 vrf ISP-1
neighbor 121.13.55.1 remote-as 1000
neighbor 121.13.55.1 activate
neighbor 172.0.2.2 remote-as 65000
neighbor 172.0.2.2 activate
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 41/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
neighbor 172.0.2.2 next-hop-self
neighbor 172.0.2.2 default-originate
exit-address-family
!
address-family ipv4 vrf ISP-2
neighbor 121.23.66.1 remote-as 2000
neighbor 121.23.66.1 activate
neighbor 172.0.3.2 remote-as 65000
neighbor 172.0.3.2 activate
neighbor 172.0.3.2 next-hop-self
neighbor 172.0.3.2 default-originate
exit-address-family
WAN-R-4 Configuration
hostname WAN-R-4
!
vrf definition ISP-1
rd 65000:1
!
address-family ipv4
exit-address-family
!
vrf definition ISP-2
rd 65000:2
!
address-family ipv4
exit-address-family
!
interface GigabitEthernet1
vrf forwarding ISP-1
ip address 172.0.2.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet2
vrf forwarding ISP-2
ip address 172.0.3.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet5
vrf forwarding ISP-2
ip address 121.24.55.2 255.255.255.252
negotiation auto
!
interface GigabitEthernet6
vrf forwarding ISP-1
ip address 121.14.66.2 255.255.255.252
negotiation auto
!
router bgp 65000
bgp router-id 16.16.16.16
bgp log-neighbor-changes
!
address-family ipv4 vrf ISP-1
neighbor 121.14.66.1 remote-as 1000
neighbor 121.14.66.1 activate
neighbor 172.0.2.2 remote-as 65000
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 42/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
neighbor 172.0.2.2 activate
neighbor 172.0.2.2 next-hop-self
neighbor 172.0.2.2 default-originate
exit-address-family
!
address-family ipv4 vrf ISP-2
neighbor 121.24.55.1 remote-as 2000
neighbor 121.24.55.1 activate
neighbor 172.0.3.2 remote-as 65000
neighbor 172.0.3.2 activate
neighbor 172.0.3.2 next-hop-self
neighbor 172.0.3.2 default-originate
exit-address-family
ToR-SW-3 Configuration
hostname ToR-SW-3
!
vlan 1000
name VMotion-LAN
!
interface GigabitEthernet0/0
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet0/3
switchport trunk allowed vlan 1000
switchport trunk encapsulation dot1q
switchport mode trunk
ToR-SW-4 Configuration
hostname ToR-SW-4
!
vlan 1000
name VMotion-LAN
!
interface GigabitEthernet0/0
switchport access vlan 1000
switchport mode access
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
switchport access vlan 1000
switchport mode access
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 43/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
interface GigabitEthernet0/3
switchport trunk allowed vlan 1000
switchport trunk encapsulation dot1q
switchport mode trunk
Server-3 Configuration
hostname Server-3
!
interface GigabitEthernet0/0
mtu 1370
ip address 192.168.22.30 255.255.255.0
no shutdown
!
enable secret Secure123
!
username admin privilege 15 secret Secure123
!
ip route 0.0.0.0 0.0.0.0 192.168.22.254
!
line vty 0 4
login local
transport input telnet
Server-4 Configuration
hostname Server-4
!
interface GigabitEthernet0/0
mtu 1370
ip address 192.168.22.40 255.255.255.0
no shutdown
!
enable secret Secure123
!
username admin privilege 15 secret Secure123
!
ip route 0.0.0.0 0.0.0.0 192.168.22.254
!
line vty 0 4
login local
transport input telnet
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 44/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 45/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 46/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 47/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Once, the F5 has been successfully setup, you can try to access the servers
using virtual server IP address. Since, we are running quite a lot of Nexus
switches and devices with the EVE-NG, the response may be slow
sometimes.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 48/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Figure 42 - Accessing Servers using F5 Virtual IP address To Test Load Balancing from
Developer-PC-2
hostname ISP-1
!
interface GigabitEthernet3
description CONNECT-TO-WAN-R-1-Gi-3
ip address 121.1.33.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet4
ip address 121.2.44.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet5
ip address 121.13.55.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet6
ip address 121.14.66.1 255.255.255.252
negotiation auto
!
router bgp 1000
bgp router-id 101.101.101.101
bgp log-neighbor-changes
neighbor 121.1.33.2 remote-as 64513
neighbor 121.2.44.2 remote-as 64513
neighbor 121.13.55.2 remote-as 65000
neighbor 121.14.66.2 remote-as 65000
!
address-family ipv4
neighbor 121.1.33.2 activate
neighbor 121.1.33.2 default-originate
neighbor 121.2.44.2 activate
neighbor 121.2.44.2 default-originate
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 49/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
neighbor 121.13.55.2 activate
neighbor 121.13.55.2 default-originate
neighbor 121.14.66.2 activate
neighbor 121.14.66.2 default-originate
exit-address-family
hostname ISP-2
!
interface GigabitEthernet3
ip address 121.2.33.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet4
ip address 121.1.44.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet5
ip address 121.24.55.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet6
ip address 121.23.66.1 255.255.255.252
negotiation auto
!
router bgp 2000
bgp router-id 202.202.202.202
bgp log-neighbor-changes
neighbor 121.1.44.2 remote-as 64513
neighbor 121.2.33.2 remote-as 64513
neighbor 121.23.66.2 remote-as 65000
neighbor 121.24.55.2 remote-as 65000
!
address-family ipv4
neighbor 121.1.44.2 activate
neighbor 121.1.44.2 default-originate
neighbor 121.2.33.2 activate
neighbor 121.2.33.2 default-originate
neighbor 121.23.66.2 activate
neighbor 121.23.66.2 default-originate
neighbor 121.24.55.2 activate
neighbor 121.24.55.2 default-originate
exit-address-family
3. Overlay Configurations
As I explained during the overview, this is where actual BGP EVPN
configuration begin.
feature nv overlay
feature vn-segment-vlan-based
nv overlay evpn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 50/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
route-map NEXTHOP-PERMIT permit 10
set ip next-hop unchanged
!
router bgp 65501
address-family l2vpn evpn
nexthop route-map NEXTHOP-PERMIT
retain route-target all
!
neighbor 11.11.11.11
remote-as 64611
description BGP-Overlay-To-NX9k-Leaf-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
!
neighbor 22.22.22.22
remote-as 64622
description BGP-Overlay-To-NX9k-Leaf-2
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
!
neighbor 33.33.33.33
remote-as 64633
description BGP-Overlay-To-NX9k-Border-Leaf-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
!
neighbor 44.44.44.44
remote-as 64644
description BGP-Overlay-To-NX9k-Border-Leaf-2
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 51/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
feature nv overlay
feature vn-segment-vlan-based
nv overlay evpn
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
route-map NEXTHOP-PERMIT permit 10
set ip next-hop unchanged
!
router bgp 65502
address-family l2vpn evpn
nexthop route-map NEXTHOP-PERMIT
retain route-target all
!
neighbor 11.11.11.11
remote-as 64611
description BGP-Overlay-To-NX9k-Leaf-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
!
neighbor 22.22.22.22
remote-as 64622
description BGP-Overlay-To-NX9k-Leaf-2
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
!
neighbor 33.33.33.33
remote-as 64633
description BGP-Overlay-To-NX9k-Border-Leaf-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
!
neighbor 44.44.44.44
remote-as 64644
description BGP-Overlay-To-NX9k-Border-Leaf-2
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 52/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
route-map NEXTHOP-PERMIT out
rewrite-evpn-rt-asn
nv overlay evpn
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
vlan 500
vn-segment 5000
!
vlan 1000
vn-segment 10000
!
interface Vlan500
ip forward
!
interface Vlan1000
ip forward
!
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 5000
ingress-replication protocol bgp
member vni 10000
ingress-replication protocol bgp
!
router bgp 64611
neighbor 1.1.1.1
remote-as 65501
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 2.2.2.2
remote-as 65502
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
# This is DC Inter-Connect-Configuration. There are
so many ways to achieve this.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 53/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
router bgp 64611
neighbor 77.77.77.77
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 88.88.88.88
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
vni 10000 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
vlan 500
vn-segment 5000
!
vlan 1000
vn-segment 10000
!
interface Vlan500
ip forward
!
interface Vlan1000
ip forward
!
interface nve1
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 54/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 5000
ingress-replication protocol bgp
member vni 10000
ingress-replication protocol bgp
!
router bgp 64622
neighbor 1.1.1.1
remote-as 65501
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 2.2.2.2
remote-as 65502
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
# This is DC Inter-Connect-Configuration. There are
so many ways to achieve this.
!
neighbor 77.77.77.77
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 88.88.88.88
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 55/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
vni 10000 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay
!
vlan 126
vn-segment 12600
!
vlan 150
vn-segment 15000
!
vlan 500
vn-segment 5000
!
ip prefix-list DC-1-Developer-Network seq 5 permit
30.100.100.0/24
ip prefix-list L3-VNI-LINK-TO-PA-FW seq 5 permit
30.126.126.0/29
!
route-map DC-1-Developer-Network permit 10
match ip address prefix-list DC-1-Developer-
Network
!
route-map L3-VNI-LINK-TO-PA-FW permit 10
match ip address prefix-list L3-VNI-LINK-TO-PA-FW
!
route-map STATIC permit 10
match route-type local
!
vrf context DC-1-Developer-Network
vni 15000
ip route 0.0.0.0/0 30.126.126.1
rd 64633:15000
address-family ipv4 unicast
route-target import 64633:12600
route-target import 64633:12600 evpn
route-target import 64633:15000
route-target import 64633:15000 evpn
route-target export 64633:12600
route-target export 64633:12600 evpn
route-target export 64633:15000
route-target export 64633:15000 evpn
vrf context L3-VNI-LINK-TO-PA-FW
vni 12600
ip route 0.0.0.0/0 30.126.126.1
rd 64633:12600
address-family ipv4 unicast
route-target import 64633:12600
route-target import 64633:12600 evpn
route-target import 64633:15000
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 56/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
route-target import 64633:15000 evpn
route-target export 64633:12600
route-target export 64633:12600 evpn
route-target export 64633:15000
route-target export 64633:15000 evpn
!
interface Vlan126
vrf member L3-VNI-LINK-TO-PA-FW
ip address 30.126.126.2/29
fabric forwarding mode anycast-gateway
!
interface Vlan150
vrf member DC-1-Developer-Network
ip address 30.100.100.1/24
fabric forwarding mode anycast-gateway
!
interface Vlan500
ip forward
!
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 5000
ingress-replication protocol bgp
member vni 12600 associate-vrf
member vni 15000 associate-vrf
!
router bgp 64633
neighbor 1.1.1.1
remote-as 65501
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 2.2.2.2
remote-as 65502
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
vrf DC-1-Developer-Network
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map DC-1-Developer-
Network
redistribute static route-map STATIC
vrf L3-VNI-LINK-TO-PA-FW
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map L3-VNI-LINK-TO-
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 57/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
PA-FW
redistribute static route-map STATIC
!
# This is DC Inter-Connect-Configuration. There are
so many ways to achieve this.
!
router bgp 64633
neighbor 55.55.55.55
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 66.66.66.66
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
vni 12600 l2
rd auto
route-target import auto
route-target export auto
vni 15000 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay
!
vlan 126
vn-segment 12600
!
vlan 150
vn-segment 15000
!
vlan 500
vn-segment 5000
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 58/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
ip prefix-list DC-1-Developer-Network seq 5 permit
30.100.100.0/24
ip prefix-list L3-VNI-LINK-TO-PA-FW seq 5 permit
30.126.126.0/29
!
route-map DC-1-Developer-Network permit 10
match ip address prefix-list DC-1-Developer-
Network
!
route-map L3-VNI-LINK-TO-PA-FW permit 10
match ip address prefix-list L3-VNI-LINK-TO-PA-FW
!
route-map STATIC permit 10
match route-type local
!
vrf context DC-1-Developer-Network
vni 15000
ip route 0.0.0.0/0 30.126.126.1
rd 64644:15000
address-family ipv4 unicast
route-target import 64644:12600
route-target import 64644:12600 evpn
route-target import 64644:15000
route-target import 64644:15000 evpn
route-target export 64644:12600
route-target export 64644:12600 evpn
route-target export 64644:15000
route-target export 64644:15000 evpn
vrf context L3-VNI-LINK-TO-PA-FW
vni 12600
ip route 0.0.0.0/0 30.126.126.1
rd 64644:12600
address-family ipv4 unicast
route-target import 64644:12600
route-target import 64644:12600 evpn
route-target import 64644:15000
route-target import 64644:15000 evpn
route-target export 64644:12600
route-target export 64644:12600 evpn
route-target export 64644:15000
route-target export 64644:15000 evpn
!
interface Vlan126
vrf member L3-VNI-LINK-TO-PA-FW
ip address 30.126.126.2/29
fabric forwarding mode anycast-gateway
!
interface Vlan150
vrf member DC-1-Developer-Network
ip address 30.100.100.1/24
fabric forwarding mode anycast-gateway
!
interface Vlan500
ip forward
!
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 59/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
member vni 5000
ingress-replication protocol bgp
member vni 12600 associate-vrf
member vni 15000 associate-vrf
!
router bgp 64633
neighbor 1.1.1.1
remote-as 65501
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 2.2.2.2
remote-as 65502
description BGP-Overlay-To-Spine-1
update-source loopback0
ebgp-multihop 2
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
vrf DC-1-Developer-Network
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map DC-1-Developer-
Network
redistribute static route-map STATIC
vrf L3-VNI-LINK-TO-PA-FW
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map L3-VNI-LINK-TO-
PA-FW
redistribute static route-map STATIC
!
# This is DC Inter-Connect-Configuration. There are
so many ways to achieve this.
!
router bgp 64633
neighbor 55.55.55.55
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 66.66.66.66
remote-as 65000
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 60/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
vni 12600 l2
rd auto
route-target import auto
route-target export auto
vni 15000 l2
rd auto
route-target import auto
route-target export auto
nv overlay evpn
feature bgp
feature vn-segment-vlan-based
feature nv overlay
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
router bgp 65000
router-id 3.3.3.3
!
template peer iBGP-EVPN
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
!
neighbor 55.55.55.55
inherit peer iBGP-EVPN
!
neighbor 66.66.66.66
inherit peer iBGP-EVPN
!
neighbor 77.77.77.77
inherit peer iBGP-EVPN
!
neighbor 88.88.88.88
inherit peer iBGP-EVPN
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 61/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
NX9K-Spine-4 Overlay Configuration
nv overlay evpn
feature bgp
feature vn-segment-vlan-based
feature nv overlay
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
router bgp 65000
router-id 4.4.4.4
!
template peer iBGP-EVPN
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
route-reflector-client
!
neighbor 55.55.55.55
inherit peer iBGP-EVPN
!
neighbor 66.66.66.66
inherit peer iBGP-EVPN
!
neighbor 77.77.77.77
inherit peer iBGP-EVPN
!
neighbor 88.88.88.88
inherit peer iBGP-EVPN
feature vn-segment-vlan-based
feature nv overlay
feature bgp
nv overlay evpn
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
!
vlan 126
vn-segment 12600
!
vlan 150
vn-segment 15000
!
vlan 500
vn-segment 5000
!
vlan 1000
vn-segment 10000
!
ip prefix-list DC-1-Developer-Network seq 5 permit
30.200.200.0/24
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 62/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
ip prefix-list L3-VNI-LINK-TO-PA-FW seq 5 permit
30.0.126.0/29
ip prefix-list LOOPBACKS seq 5 permit 11.11.11.11/32
ip prefix-list LOOPBACKS seq 10 permit
22.22.22.22/32
ip prefix-list LOOPBACKS seq 15 permit
33.33.33.33/32
ip prefix-list LOOPBACKS seq 20 permit
44.44.44.44/32
ip prefix-list LOOPBACKS seq 25 permit 1.0.0.1/32
ip prefix-list LOOPBACKS seq 30 permit 1.0.0.3/32
ip prefix-list REDISTRIBUTION-OSPF-TO-BGP seq 5
permit 77.77.77.77/32
ip prefix-list REDISTRIBUTION-OSPF-TO-BGP seq 10
permit 88.88.88.88/32
ip prefix-list REDISTRIBUTION-OSPF-TO-BGP seq 15
permit 1.0.0.34/32
!
route-map DC-1-Developer-Network permit 10
match ip address prefix-list DC-1-Developer-
Network
route-map L3-VNI-LINK-TO-PA-FW permit 10
match ip address prefix-list L3-VNI-LINK-TO-PA-FW
route-map REDISTRIBUTE-LOOPBACKS-TO-BGP permit 10
match ip address prefix-list REDISTRIBUTION-OSPF-
TO-BGP
route-map REDISTRIBUTE-LOOPBACKS-TO-OSPF permit 10
match ip address prefix-list LOOPBACKS
match route-type internal
route-map STATIC permit 10
match route-type local
!
vrf context DC-1-Developer-Network
vni 15000
ip route 0.0.0.0/0 30.0.126.1
rd 65000:15000
address-family ipv4 unicast
route-target import 65000:12600
route-target import 65000:12600 evpn
route-target import 65000:15000
route-target import 65000:15000 evpn
route-target export 65000:12600
route-target export 65000:12600 evpn
route-target export 65000:15000
route-target export 65000:15000 evpn
vrf context L3-VNI-LINK-TO-PA-FW
vni 12600
ip route 0.0.0.0/0 30.0.126.1
rd 65000:126000
address-family ipv4 unicast
route-target import 65000:12600
route-target import 65000:12600 evpn
route-target import 65000:15000
route-target import 65000:15000 evpn
route-target export 65000:12600
route-target export 65000:12600 evpn
route-target export 65000:15000
route-target export 65000:15000 evpn
!
interface Vlan126
vrf member L3-VNI-LINK-TO-PA-FW
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 63/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
ip address 30.0.126.2/29
fabric forwarding mode anycast-gateway
!
interface Vlan150
vrf member DC-1-Developer-Network
ip address 30.200.200.1/24
fabric forwarding mode anycast-gateway
!
interface Vlan500
ip forward
!
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 5000
ingress-replication protocol bgp
member vni 12600 associate-vrf
member vni 15000 associate-vrf
!
router ospf 1
redistribute bgp 65000 route-map REDISTRIBUTE-
LOOPBACKS-TO-OSPF
!
router bgp 65000
router-id 55.55.55.55
address-family ipv4 unicast
network 1.0.0.56/32
network 55.55.55.55/32
redistribute ospf 1 route-map REDISTRIBUTE-
LOOPBACKS-TO-BGP
!
template peer iBGP-EVPN
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
!
neighbor 3.3.3.3
inherit peer iBGP-EVPN
!
neighbor 4.4.4.4
inherit peer iBGP-EVPN
!
neighbor 10.0.31.1
remote-as 65000
address-family ipv4 unicast
next-hop-self
!
vrf DC-1-Developer-Network
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map DC-1-Developer-
Network
redistribute static route-map STATIC
!
vrf L3-VNI-LINK-TO-PA-FW
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map L3-VNI-LINK-TO-
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 64/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
PA-FW
redistribute static route-map STATIC
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
vni 12600 l2
rd auto
route-target import auto
route-target export auto
vni 15000 l2
rd auto
route-target import auto
route-target export auto
!
# DC-Inter-Connect
!
router bgp 65000
neighbor 33.33.33.33
remote-as 64633
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 44.44.44.44
remote-as 64644
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
feature vn-segment-vlan-based
feature nv overlay
feature bgp
nv overlay evpn
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
!
vlan 126
vn-segment 12600
!
vlan 150
vn-segment 15000
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 65/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
!
vlan 500
vn-segment 5000
!
vlan 1000
vn-segment 10000
!
ip prefix-list DC-1-Developer-Network seq 5 permit
30.200.200.0/24
ip prefix-list L3-VNI-LINK-TO-PA-FW seq 5 permit
30.0.126.0/29
ip prefix-list LOOPBACKS seq 5 permit 11.11.11.11/32
ip prefix-list LOOPBACKS seq 10 permit
22.22.22.22/32
ip prefix-list LOOPBACKS seq 15 permit
33.33.33.33/32
ip prefix-list LOOPBACKS seq 20 permit
44.44.44.44/32
ip prefix-list LOOPBACKS seq 25 permit 1.0.0.1/32
ip prefix-list LOOPBACKS seq 30 permit 1.0.0.3/32
ip prefix-list REDISTRIBUTION-OSPF-TO-BGP seq 5
permit 77.77.77.77/32
ip prefix-list REDISTRIBUTION-OSPF-TO-BGP seq 10
permit 88.88.88.88/32
ip prefix-list REDISTRIBUTION-OSPF-TO-BGP seq 15
permit 1.0.0.34/32
!
route-map DC-1-Developer-Network permit 10
match ip address prefix-list DC-1-Developer-
Network
route-map L3-VNI-LINK-TO-PA-FW permit 10
match ip address prefix-list L3-VNI-LINK-TO-PA-FW
route-map REDISTRIBUTE-LOOPBACKS-TO-BGP permit 10
match ip address prefix-list REDISTRIBUTION-OSPF-
TO-BGP
route-map REDISTRIBUTE-LOOPBACKS-TO-OSPF permit 10
match ip address prefix-list LOOPBACKS
match route-type internal
route-map STATIC permit 10
match route-type local
!
vrf context DC-1-Developer-Network
vni 15000
ip route 0.0.0.0/0 30.0.126.1
rd 65000:15000
address-family ipv4 unicast
route-target import 65000:12600
route-target import 65000:12600 evpn
route-target import 65000:15000
route-target import 65000:15000 evpn
route-target export 65000:12600
route-target export 65000:12600 evpn
route-target export 65000:15000
route-target export 65000:15000 evpn
!
vrf context L3-VNI-LINK-TO-PA-FW
vni 12600
ip route 0.0.0.0/0 30.0.126.1
rd 65000:126000
address-family ipv4 unicast
route-target import 65000:12600
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 66/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
route-target import 65000:12600 evpn
route-target import 65000:15000
route-target import 65000:15000 evpn
route-target export 65000:12600
route-target export 65000:12600 evpn
route-target export 65000:15000
route-target export 65000:15000 evpn
!
interface Vlan126
vrf member L3-VNI-LINK-TO-PA-FW
ip address 30.0.126.2/29
fabric forwarding mode anycast-gateway
!
interface Vlan150
vrf member DC-1-Developer-Network
ip address 30.200.200.1/24
fabric forwarding mode anycast-gateway
!
interface Vlan500
ip forward
!
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 5000
ingress-replication protocol bgp
member vni 12600 associate-vrf
member vni 15000 associate-vrf
!
router ospf 1
redistribute bgp 65000 route-map REDISTRIBUTE-
LOOPBACKS-TO-OSPF
!
router bgp 65000
router-id 66.66.66.66
address-family ipv4 unicast
network 1.0.0.56/32
network 66.66.66.66/32
redistribute ospf 1 route-map REDISTRIBUTE-
LOOPBACKS-TO-BGP
!
template peer iBGP-EVPN
remote-as 65000
update-source loopback0
address-family l2vpn evpn
send-community
send-community extended
!
neighbor 3.3.3.3
inherit peer iBGP-EVPN
!
neighbor 4.4.4.4
inherit peer iBGP-EVPN
!
neighbor 10.0.31.1
remote-as 65000
address-family ipv4 unicast
next-hop-self
!
vrf DC-1-Developer-Network
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 67/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map DC-1-Developer-
Network
redistribute static route-map STATIC
!
vrf L3-VNI-LINK-TO-PA-FW
address-family ipv4 unicast
advertise l2vpn evpn
redistribute direct route-map L3-VNI-LINK-TO-
PA-FW
redistribute static route-map STATIC
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
vni 12600 l2
rd auto
route-target import auto
route-target export auto
vni 15000 l2
rd auto
route-target import auto
route-target export auto
!
# DC-Inter-Connect
!
router bgp 65000
neighbor 33.33.33.33
remote-as 64633
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
!
neighbor 44.44.44.44
remote-as 64644
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
feature bgp
feature vn-segment-vlan-based
feature nv overlay
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 68/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
nv overlay evpn
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
vlan 500
vn-segment 5000
!
vlan 1000
vn-segment 10000
!
interface Vlan500
ip forward
!
interface Vlan1000
ip forward
!
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 5000
ingress-replication protocol bgp
member vni 10000
ingress-replication protocol bgp
!
!
router bgp 65000
router-id 77.77.77.77
address-family l2vpn evpn
!
template peer iBGP-EVPN
remote-as 65000
update-source loopback0
address-family ipv4 unicast
next-hop-self
address-family l2vpn evpn
send-community
send-community extended
!
neighbor 3.3.3.3
inherit peer iBGP-EVPN
!
neighbor 4.4.4.4
inherit peer iBGP-EVPN
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
vni 10000 l2
rd auto
route-target import auto
route-target export auto
!
#DC-Inter-Connect
!
router bgp 65000
neighbor 11.11.11.11
remote-as 64611
description DC-VxLAN-Inter-Connect
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 69/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 22.22.22.22
remote-as 64622
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
feature bgp
feature vn-segment-vlan-based
feature nv overlay
nv overlay evpn
!
fabric forwarding anycast-gateway-mac 000a.000b.000c
!
vlan 500
vn-segment 5000
!
vlan 1000
vn-segment 10000
!
interface Vlan500
ip forward
!
interface Vlan1000
ip forward
!
interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback0
member vni 5000
ingress-replication protocol bgp
member vni 10000
ingress-replication protocol bgp
!
!
router bgp 65000
router-id 88.88.88.88
address-family l2vpn evpn
!
template peer iBGP-EVPN
remote-as 65000
update-source loopback0
address-family ipv4 unicast
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 70/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
next-hop-self
address-family l2vpn evpn
send-community
send-community extended
!
neighbor 3.3.3.3
inherit peer iBGP-EVPN
!
neighbor 4.4.4.4
inherit peer iBGP-EVPN
!
evpn
vni 5000 l2
rd auto
route-target import auto
route-target export auto
vni 10000 l2
rd auto
route-target import auto
route-target export auto
!
#DC-Inter-Connect
!
router bgp 65000
neighbor 11.11.11.11
remote-as 64611
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
neighbor 22.22.22.22
remote-as 64622
description DC-VxLAN-Inter-Connect
update-source loopback0
ebgp-multihop 20
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
rewrite-evpn-rt-asn
4. Verifications
Verifications and packet capture is important to make sure the traffic is
actually encapsulated and VXLAN is actually being used as a transport.
Figure 43 shows how many EVPN paths was received from NX9K-Leaf-1.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 71/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 72/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
This is the ultimate goal of this lab being able to extend L2 connectivity
across multiple DC.
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 73/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Figure 49 - Testing VXLAN Across DC with VNI-100 from Server 1 using Broadcast
Ping
I want to add at least 2 more sites (total 4 sites) to become more realistic.
However, my server is reaching its capacity.
Comments
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 74/75
6/28/24, 7:55 AM (1) Multi-Site VXLAN Lab with BGP EVPN | LinkedIn
Rob Riker and 118 others · 7 comments
119
Add a comment…
Most relevant
Like · 1 Reply
Noooooiiice!!!
Like Reply
Follow
https://www.linkedin.com/pulse/multi-site-vxlan-lab-bgp-evpn-part-1-henry-thompson-m3yme/ 75/75