17 Dynamic Routing Protocols - Answer Key
17 Dynamic Routing Protocols - Answer Key
In this lab you will examine features which are common to all Interior Gateway
Protocols. Basic configuration for various IGPs is included but is not the focus of
this lab exercise. Configuration for each of the IGPs will be covered in detail later.
router rip
network 10.0.0.0
no auto-summary
The updates are being sent on the broadcast address 255.255.255.255. All hosts
on the subnet must process the packets.
R1#debug ip rip
RIP protocol debugging is on
R1#RIP: sending v1 update to 255.255.255.255 via
FastEthernet0/0 (10.0.0.1)
RIP: build update entries
network 10.0.1.0 metric 1
network 10.0.2.0 metric 1
router rip
version 2
The updates are being sent on the RIPv2 multicast address 224.0.0.9. Only
RIPv2 routers will process the packets beyond layer 3.
R1#undebug all
All possible debugging has been turned off
6) Check that RIP routes have been added to R1 and it has a route to every
subnet in the lab.
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
7) Why are there two routes to the 10.1.1.0/24 network in the routing table?
Two paths to 10.1.1.0/24 have an equal metric – a hop count of 2. Both routes
are installed in the routing table and the router will perform Equal Cost Load
Balancing between the next hops of 10.0.3.2 and 10.0.0.2.
Comparing Routing Protocols
router ospf 1
network 10.0.0.0 0.255.255.255 area 0
10) Give OSPF time to converge. Are RIP routes included in the routing table
on R1 now? Why or why not?
The RIP routes are replaced by OSPF because its Administrative Distance of
110 is preferred to RIP’s AD of 120.
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
OSPF uses cost as its metric which takes into account interface bandwidth. The
interfaces on R5 have a configured bandwidth of 10Mbps. The interfaces along
the top path of the network topology all have the default FastEthernet bandwidth
of 100Mbps so this route is preferred. All traffic will go via the next hop 10.0.0.2.
12) Disable interface FastEthernet 0/0 on R2. What do you expect to happen
to R1’s routing table?
OSPF will reconverge. The routes to the 10.1.0.0 networks via R2 will be
removed from the routing table and replaced with routes via R5.
The new routes have a higher metric. This is why they were not in the routing
table when the path via R2 was up.
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
RIP is a Distance Vector routing protocol so it only knows its directly connected
neighbors and the lists of networks those neighbors have advertised.
OSPF is a Link State routing protocol so it knows the state of every link on every
router in its area.
no router ospf 1
Yes. RIP is still running so RIP routes will replace the removed OSPF routes in
the routing table.
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
A hop count of 2.
19) Why is there only one route on R1 to the 10.1.1.0/24 network now?
R2(config)#interface f0/0
R2(config-if)#no shut
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile,
B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
21) Enter the commands below on each router to provision a basic EIGRP
configuration and enable EIGRP on every interface.
22) What changes do you expect to see in the routing tables? Why?
The RIP routes will be replaced by EIGRP because its Administrative Distance of
90 is preferred to RIP’s AD of 120.
23) Verify the changes to the routing table on R1.
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
25) Why is there only one route to the 10.1.1.0/24 network on R1?
EIGRP uses a composite metric which takes into account interface bandwidth
and delay. The interfaces on R5 have a configured bandwidth of 10Mbps. The
interfaces along the top path of the network topology all have the default
FastEthernet bandwidth of 100Mbps so this route is preferred. All traffic will go
via the next hop 10.0.0.2.
28) What changes do you expect to see to the routing table on R1?
The summary route will be added to the routing table but not used because it has
a prefix length of /16, compared to the EIGRP routes which have a longer prefix
length of /24.
If individual floating static routes had been added for each of the /24 destination
networks then these would not have appeared in the routing table (unless a link
went down) because EIGRP has a better Administrative Distance.
29) Verify the changes to the routing table on R1.
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
30) Verify that traffic from PC1 to PC3 still goes via R2.
C:\>tracert 10.1.2.10
1 1 ms 0 ms 1 ms 10.0.1.1
2 0 ms 3 ms 0 ms 10.0.0.2
3 1 ms 0 ms 0 ms 10.1.0.1
4 0 ms 1 ms 0 ms 10.1.1.1
5 * 0 ms 0 ms 10.1.2.10
Trace complete.
R2(config)#interface f0/0
R2(config-if)#shutdown
32) What changes do you expect to see on R1’s routing table?
R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
C:\>ping 10.1.2.10
C:\>tracert 10.1.2.10
1 0 ms 0 ms 1 ms 10.0.1.1
2 0 ms 0 ms 0 ms 10.0.3.2
3 0 ms 0 ms 0 ms 10.1.3.1
4 0 ms 0 ms 1 ms 10.1.2.10
Trace complete.
R2(config)#interface f0/0
R2(config-if)#no shutdown
Loopback Interfaces
R1(config)#interface loopback0
R1(config-if)#ip address 192.168.0.1 255.255.255.255
R2(config)#interface loopback0
R2(config-if)#ip address 192.168.0.2 255.255.255.255
R3(config)#interface loopback0
R3(config-if)#ip address 192.168.0.3 255.255.255.255
R4(config)#interface loopback0
R4(config-if)#ip address 192.168.0.4 255.255.255.255
R5(config)#interface loopback0
R5(config-if)#ip address 192.168.0.5 255.255.255.255
39) Is there connectivity to the loopback interfaces from the PCs? Why or why
not?
There is no connectivity from the PCs to the loopback interfaces because they
are not in the routing tables of the routers (apart from the local loopback interface
on each router). The loopback interfaces are not in the routing tables because
they are in the 192.168.0.0/24 range which has not been included in the routing
protocol.
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
40) Enter the commands below on each router to include the loopback
interfaces in EIGRP.
C:\>ping 192.168.0.5
43) Enter the command below to verify that R1 has established EIGRP
adjacencies with R2 and R5.
R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.0.3.2 Fa1/1 14 00:17:21 33 198 0 16
0 10.0.0.2 Fa0/0 11 00:19:21 36 216 0 32
44) Verify that traffic from R5 to the directly connected interfaces on R1 goes
via the FastEthernet 0/1 interface.
R5#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
46) What changes do you expect to see in the routing table on R5 and why?
The EIGRP adjacency between R1 and R5 will go down. All EIGRP routes via R1
will be removed from the routing table and replaced with routes via R4.
Configuring the loopback interface as a passive interface on R1 does not affect
any routing tables but is a best practice.
R1(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.0.3.2
(FastEthernet1/1) is down: holding time expired