Activity A

Download as pdf or txt
Download as pdf or txt
You are on page 1of 15

code

Part 1: Configure Basic Device Settings


Configuration for Branch_1

no ip domain-lookup

hostname Branch_1

enable secret enPa$$2

line vty 0 4
password vtyPa$$2
login
exit

line console 0
password conPa$$2
login
exit

banner motd "unauthorized access is prohibited"

service password-encryption

interface serial 0/0/1


clock rate 64000
exit

Configuration for Branch_2


no ip domain-lookup

hostname Branch_2

enable secret enPa$$2

line vty 0 4
password vtyPa$$2
login
exit

line console 0
password conPa$$2
login
exit

banner motd "unauthorized access is prohibited"

service password-encryption

interface serial 0/0/0


clock rate 64000
exit

interface serial 0/0/1


clock rate 64000
exit

Configuration for Branch_3

no ip domain-lookup

hostname Branch_3
enable secret enPa$$2

line vty 0 4
password vtyPa$$2
login
exit

line console 0
password conPa$$2
login
exit

banner motd "unauthorized access is prohibited"

service password-encryption

Part 2: IPv4 Configuration


Configuration for Branch_1

interface gigabitEthernet 0/0


ip address 172.18.1.1 255.255.255.0
no shutdown
exit

interface gigabitEthernet 0/1


ip address 172.18.2.1 255.255.255.0
no shutdown
exit

interface serial 0/0/0


ip address 192.168.1.1 255.255.255.252
no shutdown
exit

interface serial 0/0/1


ip address 192.168.1.9 255.255.255.252
clock rate 64000
no shutdown
exit

Configuration for Branch_2

interface gigabitEthernet 0/0


ip address 10.1.1.1 255.255.255.224
no shutdown
exit

interface serial 0/0/0


ip address 192.168.1.2 255.255.255.252
no shutdown
exit

interface serial 0/0/1


ip address 192.168.1.5 255.255.255.252
clock rate 64000
no shutdown
exit

interface serial 0/1/0


ip address 200.10.0.10 255.255.0.0
no shutdown
exit

Configuration for Branch_3


interface gigabitEthernet 0/0
ip address 172.18.3.1 255.255.255.0
no shutdown
exit

interface gigabitEthernet 0/1


ip address 172.18.4.1 255.255.255.0
no shutdown
exit

interface serial 0/0/0


ip address 192.168.1.10 255.255.255.252
no shutdown
exit

interface serial 0/0/1


ip address 192.168.1.6 255.255.255.252
clock rate 64000
no shutdown
exit

Part 3: IPv6 Configuration


Configuration for Branch_1

ipv6 unicast-routing

interface gigabitEthernet 0/0


ipv6 address 2001:DB8:ACAD:A::1/64
no shutdown
exit

interface gigabitEthernet 0/1


ipv6 address 2001:DB8:ACAD:B::1/64
no shutdown
exit

interface serial 0/0/0


ipv6 address 2001:DB8:ACAD:1::1/64
no shutdown
exit

interface serial 0/0/1


ipv6 address 2001:DB8:ACAD:3::1/64
no shutdown
exit

Configuration for Branch_2

ipv6 unicast-routing

interface gigabitEthernet 0/0


ipv6 address 2001:DB8:ACAD:E::1/64
no shutdown
exit

interface serial 0/0/0


ipv6 address 2001:DB8:ACAD:1::2/64
no shutdown
exit

interface serial 0/0/1


ipv6 address 2001:DB8:ACAD:2::1/64
no shutdown
exit

interface serial 0/1/0


ipv6 address 2001:ABCD:2F:100::2/64
no shutdown
exit

Configuration for Branch_3

ipv6 unicast-routing

interface gigabitEthernet 0/0


ipv6 address 2001:DB8:ACAD:C::1/64
no shutdown
exit

interface gigabitEthernet 0/1


ipv6 address 2001:DB8:ACAD:D::1/64
no shutdown
exit

interface serial 0/0/0


ipv6 address 2001:DB8:ACAD:2::2/64
no shutdown
exit

interface serial 0/0/1


ipv6 address 2001:DB8:ACAD:3::2/64
no shutdown
exit

Part 4: IPv4 Routing Configuration


Step 1 :
write the command show Ip route
Any interface that is connected which has C should use the IP
To get Wildcard you use this formula ( 255.255.255.255-subnet
mask=wildcard )

1. Branch_1 OSPF Configuration:

router ospf 1
network 172.18.1.1 0.0.0.255 area 0
network 172.18.2.1 0.0.0.255 area 0
network 192.168.1.1 0.0.0.3 area 0
network 192.168.1.9 0.0.0.3 area 0
exit

2. Branch_2 OSPF Configuration:

router ospf 1
network 10.1.1.1 0.0.0.31 area 0
network 192.168.1.1 0.0.0.3 area 0
network 192.168.1.5 0.0.0.3 area 0
network 192.168.1.10 0.0.255.255 area 0
exit

3. Branch_3 OSPF Configuration:

router ospf 1
network 172.18.3.1 0.0.0.255 area 0
network 172.18.4.1 0.0.0.255 area 0
network 192.168.1.10 0.0.0.3 area 0
network 192.168.1.6 0.0.0.3 area 0
exit

Step 2 :
In Branch_2 only

ip route 0.0.0.0 0.0.0.0 s0/1/0

If you got the following its correct :

%Default route without gateway, if not a point-to-point interface, may impact


performance

Step 3 :
In Branch_2 only

router ospf 1
default-information originate
exit

Step 4 :
Type show ip ospf neighbor Don't use any of the Interfaces u get

1. Branch_1 Passive Interfaces Configuration:

router ospf 1
passive-interface gigabitEthernet 0/0
passive-interface gigabitEthernet 0/1
exit

2. Branch_2 Passive Interfaces Configuration:

router ospf 1
passive-interface gigabitEthernet 0/0
passive-interface serial 0/1/0
exit
3. Branch_3 Passive Interfaces Configuration:

router ospf 1
passive-interface gigabitEthernet 0/0
passive-interface gigabitEthernet 0/1
exit

Step 5 :
1. Ping Tests from Branch_1
2. Ping Tests from Branch_2
3. Ping Tests from Branch_3

Step 6 :
1. Branch_1 Bandwidth Configuration:

interface serial 0/0/0


bandwidth 128
no shutdown
exit

2. Branch_2 Bandwidth Configuration:

interface serial 0/0/0


bandwidth 128
no shutdown
exit

Step 7 :
1. Branch_2 OSPF Cost Configuration:
10^8/cost=ans
interface serial 0/0/1
ip ospf cost 1562
no shutdown
exit

2. Branch_3 OSPF Cost Configuration:

interface serial 0/0/1


ip ospf cost 1562
no shutdown
exit

Step 8 :

copy running-config startup-config

Part 5: IPv6 Routing Configuration


Step 1: incorrect
Branch_1 Configuration:

ipv6 router eigrp 200


eigrp router-id 1.1.1.1
no shutdown
exit

interface gigabitEthernet 0/0


ipv6 eigrp 200
exit

interface gigabitEthernet 0/1


ipv6 eigrp 200
exit

interface Serial 0/0/0


ipv6 eigrp 200
exit

interface Serial 0/0/1


ipv6 eigrp 200
exit

Branch_2 Configuration:

ipv6 router eigrp 200


eigrp router-id 2.2.2.2
no shutdown
exit

interface gigabitEthernet 0/0


ipv6 eigrp 200
exit

interface Serial 0/0/0


ipv6 eigrp 200
exit

interface Serial 0/0/1


ipv6 eigrp 200
exit

interface Serial 0/1/0


ipv6 eigrp 200
exit
Branch_3 Configuration:

ipv6 router eigrp 200


eigrp router-id 3.3.3.3
no shutdown
exit

interface gigabitEthernet 0/0


ipv6 eigrp 200
exit

interface gigabitEthernet 0/1


ipv6 eigrp 200
exit

interface Serial 0/0/0


ipv6 eigrp 200
exit

interface Serial 0/0/1


ipv6 eigrp 200
exit

Step 2:
Branch_2 only

ipv6 route ::/0 s0/1/0

Step 3:

ipv6 router eigrp 200


redistribute static
no shutdown
exit

Step 4:
Type show ipv6 eigrp neighbors Don't use any of the Interfaces u get
Branch_1 Configuration:

ipv6 router eigrp 200


passive-interface GigabitEthernet 0/0
passive-interface GigabitEthernet 0/1
exit

Branch_2 Configuration:

ipv6 router eigrp 200


passive-interface GigabitEthernet 0/0
passive-interface Serial 0/1/0
exit

Branch_3 Configuration:

ipv6 router eigrp 200


passive-interface GigabitEthernet 0/0
passive-interface GigabitEthernet 0/1
exit

Step 5:
1. Ping Tests from Branch_1
2. Ping Tests from Branch_2
3. Ping Tests from Branch_3

Step 6:
copy running-config startup-config

You might also like